PlatformIO Community

Visual Studio Code - PlatformIO IDE commands not working

Hi all,

right now I am using PlatformIO with Atom, but I recently saw that PlatformIO is now also available for Visual Studio Code.
As I like VScode more I want to switch …
I am using Windows 10.

I basically installed the PlatformIO IDE extension. I was a little bit confused in the first place, because there are 2 extensions available, but I think the “PlatformIO” extension is a community project, right? Anyhow, I installed the “PlatformIO IDE” extension.

VScode asked me two time sto reload the window - of course I did.
Then, I want to start a new project. So I press Ctrl + Shift + P and select “PlatformIO: Initialize or update project”.
I confirm by pressing RETURN and the follwoing error pops up: command ‘platformio-ide.initProject’ not found
In fact, no matter which command I try to execute always the command ‘xxx’ not found error pops up. I also tried restarting and re-installing the extension, but without success.

When opening an project folder, that has been created with Atom + PlatformIO, it seems that the VScode extension is working. At least I am seeing the toolbar in at the bottom (but the toolbar is only visible, when a folder has been opened). Also pressing the build button in the toolbar restults in building the project.

thanks for your help,
caldicot

Do you use Official PlatformIO IDE for VSCode 0.2.0 version? I’ve just tried to reproduce this issue I didn’t find a problem.

Please uninstall extension and install again. Does it work now?

thanks for your quick reply.

Yes, I am using the offical PlatformIO IDE extension for VSCode (v0.2.0).
I followed your advice uninstalling and installing the extension again, but unfortunately the result is the same.
Is there any chance to clear caches or something like this?

I am using the latest VSCode (v1.12.2)

Did you open project/workspace? Could you show a screenshot of an error?

I have had similar problem with the PlatformIO community extension. The solution was to install
the “Shell Commands” (I did it via the PlatformIO IDE for Atom, Menu>Install Platform Commands). I don’t know if it solve the problem with the ‘official’ PlatformIO IDE extension
on VScode, but try it.

It slightly different error, see > “command ‘platformio-ide.initProject’ not found”

Thanks for your help.

I haven’t opened any project/workspace. A new file is opened in VScode. Then I try to initialize a new PlatformIO project via the command palette and the error occurs. I’ve attached two screenshots showing the procedure …

Sorry, as I am a new user I can only upload one image per post.
Here is the 2nd one.

Please create empty folder and open it with VSCode. So, now you can use Init command. I’ll think how to improve that.

See

Thanks for your help.
When opening a workspace in VScode before initializing the PlatformIO project it is working.
Sorry for the trouble, I just didn’t get it.

Best

Please open PIO Home :houses: icon on the toolbar and open PlatformIO Project or create a new one.

1 Like