[solved] Enable just local echo in serial monitor

Hi there!

I spent some time googling and found that the serial monitor of PlatformIO did have the option to “echo” what you’re typing, but it seems to have been removed when the python backend upgraded to version 3.x.

My goal is to reproduce Arduino IDE’s Serial Monitor’s behaviour in PlatformIO’s Serial Monitor: While typing, I would like to see what I type and the answers of Arduino go with it. I tried different “Filter” modes, the only one showing the necessary info is Debug (and it’s illegible because it adds so much more info, I just want to see the echo as well, but no “tx” “rx” etc.). The Filter “colorize” seems like what I want, but unfortunately it behaves exacly as “default”.

Would anyone have an advice?


You can enable this option from Serial Monitor menu: Ctrl+T then Ctrl+H. To enable echo use Ctrl+T then Ctrl+E.

I see in PySerial repo that they returned back this option to the CLI API. Please open an issue here and I’ll add support for --echo. Do we need this option in PlatformIO IDE advanced settings list?

Thanks a lot for your reply! It solved the problem indeed.

For visitors landing here: Ctrl+T, then Ctrl+E will enable echo (it’s not necessary to go to menu first).

I can’t test it directly on PySerial because I’m missing dependencies on this system, sorry :frowning:

You can install it using Python virtualenv.

Thanks. I can now confirm that the following command will works:
python -m serial.tools.miniterm -e --eol CR

I reported the issue here: Feature Request: Serial Monitor: Bring Local Echo back · Issue #144 · platformio/platformio-atom-ide · GitHub

I am new to PlatformIO having installed it as hopefully a better IDE to program Arduino. I’m running it on Mac OSX 10.7. I also am having trouble getting the serial monitor to work. I can upload a progrm that I wrote using Arduino IDE and it complies OK. However, the program sends sensor readings to the monitor and I dont see these coming to the serial monitor when it runs. I tried some of the suggestions above but I cannot seem to find where to adjust the settings (e.g. rts 0) anywhere.
Without the local echo on the monitor, I don’t see anything I type in.

Any help would be appreciated.

Could you try this solution?

My apologies for the late response.
I tried your solution and it works…sort of - I simply invoke the terminal. When I upload my Arduino sketch - the serial monitor opens temporarily giving upload status. WHen conditon is green - I open the terminal window and issue:

pio device monitor --rts 0 --baud 9600

This will start the flow of program output to the terminal window. This is what I wanted and I’m making progress with it.

My question is: Why doesn’t it “stick”. That is, why do I need to issue the --rts 0 command each time I want to run the sketch? Why doesn’t it just start spewing program output immediately after the upload?