PlatformIO Community

SKT 1.4 Turbo firmware uploading via swd

Hi, I try to upload marlin firmware onto skt 1.4 trubo board, because the sd firmware loading does not work. I have a cheap st link v2 connected to the board and to the pc. I see the st link via windows devices and via openOCD. Open ocd shows that the board works fine : image
The problem is that platform IO does not see the port, and i cant upload the firmware, Error: Please specify upload_port for environment or use global --upload-port option. To be exact.
I tried different protocols,(mbed, balckmagic,jlink, cmsis-dap) with the same results
What shall I do ?
Thanks :slight_smile:

Practically identical topic as in

This external 3rd-party developed LPC platform at https://github.com/p3p/pio-nxplpc-arduino-lpc176x that Marlin is using can’t handle upload_protocol = stlink, not PIO itself, to be exact.

If you get it to work based on the topics above please let us know, noone has followed through with this yet. You’re already pretty close since you can connect to the target – if you have a compiled .bin firmware you might want to try the -c "program .." commands listed above.

You might however find it significantly easier to just upload the firmware via the bootloader if it still has one.

Thanks…Yes, I feel “close” but as yet no-joy. I’ve tabled the project for the time being but would still like to get STLINK programming working. As to using the bootloader, the only one I am aware of for the SKR 1.4 board uses the SD card to reflash the code. It is this very problem (ie: SD card quit working!) that has let me down the STLINK rat-hole as I figured either 1) the Boot Loader is dead or 2) SD card socket is dead/bad. I have since received a new SD card holder but haven’t had time to do a swap. I will post any progress I achieve when and if I actually make some!