SKR 1.4 bricked

hello, you said that you put the pin to GND, which pin?
thank you

The mentioned SKR1.4 turbo has a LPC1768 chipset, and if you read the datasheet it says…

In ISP mode the device accepts UART commands to erase/program etc. See readily available online documetation at e.g. Unbricking - Cookbook | Mbed and Flash Magic to Program LPC1768 Cortex-M3.

thanks for your quick reply, but that won’t solve my problem, my SKR1.4 turbo has an LPC 1769 and not LPC1768
and I can’t connect with Flashmagic

That’s weird from the pictures of the board I’ve seen, but it does not make a difference. You can see for yourself that the datasheet I linked to applies to


Thus the same pin is correct.

Have you found where you can access this pin easily on the motherboard?

here I think, but maybe I’m wrong

Yeah should be right. The schematics show

So the signal ISP_BOOT is pulled-up to 3.3V via the 10kOhm resistor R28. Also capacitor C14 is right next to it.


The resistor should have the SMD code “103” on top for 10*10^3 = 10000 Ohm. Can you confirm that? Also make sure to only directly connect the side of the resistor to GND which is connected with the P2.10 pin, not the side that is connected to the 3.3V VDD side; that would create a short. Check with a multimeter to see which side of the resistor is connected to where (direct continuity to P2.10 with practically no resistance, 10k resistance to VCC in the other case)

Note that to get to UART(0), you will have to connect a USB-UART adapter to where TXD0 and RXD0 is connected to. On that board that is


on the TFT screen connector P2. So if you have adapter hooked up that, bridged ISP_BOOT with GND, and then power up the board, the MCU should start up in ISP mode and you should be able to flash it with flashmagic.

However there’s also the possibility that the chip is simply dead…

thank you very much
your screens show me or was my mistake, I tried to flash by the SPI instead of the port TFT, I can now flash.
but the bootloader that I got here GitHub - Marsman1970/SKR-V1.3-Bootloader: KR V1.3 Bootloader may not be good, because I still cannot flash marlin via microSD

Merci beaucoup

But can you flash a Marlin binary directly from PlatformIO’s output? Or a known-good binary?

I’d recommend to make a comment in skr 1.4 turbo bootloader · Issue #346 · bigtreetech/BIGTREETECH-SKR-V1.3 · GitHub to get help on where to get the bootloader. Though the comment already says…

The lpc1769 is from a skr 1.4 turbo

So I don’t know what else might be going on here. (I’m sure you’ve already removed the ISP_BOOT <-> GND bridge, right)

yes I have deleted the ISP BOOT <-> GND bridge
no I have never succeeded by PlatformIO

maybe I have a problem with the microSD card reader

you would be able to share your bootloader which allows flashing via an external spi module

thank you

Since I dont have any 3D printer, in particular also no SKR 1.4 Turbo, I can’t dump the firmware image.

My suggestion would be to try to program the board with a simple program to check whether the chip is working okay, e.g. with an Arduino sketch. That sketch can then also check if it can read an SD card. So thus you might get closer to the actual problem (if it isn’t that the burned bootloader is wrong after all).

PlatformIO natively doesn’t support the LPC1769 chip though in the platform, only LPC1768 and other. But custom support is available.

So you can e.g. try the following PlatformIO project: GitHub - maxgerhardt/pio-nxp-lpc1769-arduino-test: Simple project for testing Arduino support on the NXP LPC1769 chip using a custom platform.

I have trouble expressing myself initially, the printer worked before I flash with “Flash Magic”
I just wanted to make a modification
as I could no longer flash with the firmware.bin in the micro sd, I thought that the bootlader was overwritten
but I don’t think the LPC 1769 is dead I just tested another bootloader that someone put on github ==> [GUIDE] No update from SD solution? · Issue #423 · bigtreetech/BIGTREETECH-SKR-V1.3 · GitHub and the problem is the same

anyway thank you for your help and sorry for my english “google translate”

can i build marlin firmware (.hex) with platformIO? to flash it then with “Flashmagic”

Flashmagic also works with .bin files. The PlatformIO Marlin build will output that .bin file (in .pio\build\<environment>\firmware.bin), which you may attempt to flash. See my text in SKR 1.4 Turbo Motherboard Without SD-CARD Reader! Bricked? - #4 by maxgerhardt regarding the bootloader and possible offset address which might not make this work.

I found the problem, I just changed my micro SD reader and now everything is working fine
thank you again for your help

bonjour tokaphi!

omg !! that photograph… i get nightmare flashbacks from my poor skr 1.4 turbo sd module! it looked similar! (nooooo!)

i am glad you have been able to resolve your issue
you deserve it (karma)

merci for your assistance in my thread
much respect to you

I have started a repo of all BIGTREETECH bootloaders. I have ripped them from the boards I own. If I do not have the board I will get one in. But while I wait for boards I have found bootloaders on the web.

I hope this resource is helpful:

I have also provided manual on how to backup and restore bootloader/Marlin firmware:

This PDF will describe all the bootloaders I am trying to place in the repository and where the bootloader resides on each BTT board:

GUIDE for UART flashing the LPC17xx Processor using the BTT writer:

Another GUIDE for UART flashing LPC17xx Processor that uses the USB to TTL serial cable/adapter:

GUIDE to UART Flashing the SKR E3 TURBO board (LPC1769) with a new compiled bootloader:

GUIDE for STM32 processor with ST-LINK:

Maybe this can help others with the problem.

1 Like

I have updated the Guides and some of these links have become broken, here are the correct links:

The repository is at:

The file explains which GUIDE should be use with which BIGTREETECH board:

PDF that describes the flash memory layout of each of the BIGTREETECH boards:

Guides on how to backup and restore the bootloader:

For Windows 10 users:

For Linux users:

Sorry about the broken links, I will not update the titles in the future. I changed the names to indicate which OS was being used.

Sincerely, GadgetAngel


Such a great topic with awesome solutions. I’m currently looking into fixing an SKR 1.4 with a broken MicroSD card reader. I tried to desolder the old one by hand but the last pin pulled the contact with it clean off of the board. Now I found out this pin actually wasn’t used, and that’s probably the reason why it just came off. I also see in pictures above that the other user had this exact same issue.

Ordered both a SPI MicroSD card reader and a replacement MicroSD slot, identical to the original one. So I’ll wait for that one to arrive first and then try to fix the board. If I don’t manage I’ll go the SPI route.

On another board (I received two broken boards from a student of mine, to repair and keep), the card gives an error when connected through USB, it’s not recognized. So I tried flashing the firmware with an FTDI programmer, but it tells me it cannot connect through the COM port with set baud rate. So I’ll have to tinker some more with that one later but I think it’s really dead dead.

There was a lot of info in this topic that cannot be found anywhere else on the web so I’m very grateful for this. Just one thing, I would like to know if the SPI route with the external slot solved the problem, it wasn’t clear to me if the user got it to work.

Check this one out: he did manage to get it to work:SKR 1.4 Turbo Motherboard Without SD-CARD Reader! Bricked? - #42 by d_man

1 Like

Ah, thanks, I had seen the topic, but only saw the opening post. Now I realize he updated saying it did indeed work and that the SKR needed a reboot in order for it to function. Good to know!

I’ll continue asking my question in that topic!