Issue with ESP32: JTAG scan chain interrogation failed


#1

Hello,
I have the following error messages when I try to debug:
Reading symbols from c:/Users/snoof/Documents/PlatformIO/Projects/181004-223214-arduino-wifiscan/.pioenvs/esp wrover kit/firmware.elf…
done.
PlatformIO Unified Debugger > http://bit.ly/pio-debug
PlatformIO: Initializing remote target…
Open On-Chip Debugger 0.10.0-dev (2018-06-04-09:51)
Licensed under GNU GPL v2
For bug reports, read
http://openocd.org/doc/doxygen/bugs.html
none separate
adapter speed: 20000 kHz
esp32 interrupt mask on
force hard breakpoints
Info : tcl server disabled
Info : telnet server disabled
Info : ftdi: if you experience problems at higher adapter clocks, try the command “ftdi_tdo_sample_edge falling”
Info : clock speed 20000 kHz
Error: JTAG scan chain interrogation failed: all ones
Error: Check JTAG interface, timings, target power, etc.
Error: Trying to use configured scan chain anyway…
Error: esp32.cpu0: IR capture error; saw 0x1f not 0x01
Warn : Bypassing JTAG setup events due to errors

I have carefully followed the instructions here:

But it is not working.

Do you have an idea how to find what the issue is?

Thanks.


#2

What jtag setup are you using?
Is that an Wrover kit? or you use a minimodule connected to some ESP32 dev board ?


#3

it is a Wrover kit.
The thing is that I’ve tried this command and I have the same error message…
openocd-esp32\bin>openocd.exe -s …/share/openocd/scripts -f interface/ftdi/esp32_devkitj_v1.cfg -f board/esp-wroom-32.cfg

and I have the same error.

I have done the same thing than in this tuto, the Debugging an ESP32 Wrover Kit part:

Is it possible that something is not right with my board?


#4

For Wrover kit and Eclipse, the best tutorial is the official one: https://docs.espressif.com/projects/esp-idf/en/latest/api-guides/jtag-debugging/configure-wrover.html but it may be hard to follow for a beginner.

For VsCode and PlatformIO, i made a jtag setup tutorial here: ESP32 & PIO Unified Debugger
You may find this tutorial and PlatformIO debug easier to use than gdb+Eclipse