Home not loading


#1

Stuck at blank page with “Loading…”. Never does anything.


Error on first run of IDE (VSCode): Failed building wheel for netifaces
#2

It seems that you have no internet connection.


#3

Always at least one jackass in the crowd so ignore comments like his/hers!
I’m having a very similar issue. Home is not loading and consistently reports a timeout. in VSCode.
I’m running Windows 10/build 1607 - 14393.1715 (in case that has any relevance). I’m running the same setup on my laptop and everything works fine…but I’m more in the habit of running things from my desktop not my laptop, so would like to get this issue resolved.

In my case, I open VSCode, either wait till PIO home attempts to load, or subsequently load it by the use of the little home icon. After 15 seconds, VSCode reports a timeout. No matter how many time I try, I cannot get past this on my desktop, but like I said, VSCode with PIO works flawlessly on my laptop…FYI, my desktop is a high end system, so no chance that any performance plays into it.


#4

I have the same problem on Mac OS, Home page not loading, I see an infinite spinner:


#5

I was lucky enough to have a working version in PlatformIO on my laptop, so I did an environment diff on the two systems, and on the working version I din’t have Python install as a separate instance. So back on the machine where PlatformIO was not working, I uninstalled pip and then uninstalled Python. Then I reinstalled PlatformIO and everything works as expected.

I’m guessing that there is simply a configuration issue here, and that reinstalling Python after installing PIO would be fine, although I haven’t tested that yet…I wanted to get you guys to test and confirm if this works for you also.


#6

What is your macOS version?


#7

Which Python did you have before?

Please provide an output from system Terminal cmd

echo %PATH%
echo %PYTHONPATH%
python --version
pip --version
pip list

#8

I use macOS High Sierra beta 10.13 (17A36a)


#9

MacBook:~ dr$ echo %PATH%
%PATH%
MacBook:~ dr$ echo %PYTHONPATH%
%PYTHONPATH%
MacBook:~ dr$ python --version
Python 2.7.10
MacBook:~ dr$ pip --version
pip 9.0.1 from /Library/Python/2.7/site-packages (python 2.7)


#10

MacBook:~ dr$ pip list
altgraph (0.10.2)
arrow (0.10.0)
awscli (1.11.71)
bdist-mpkg (0.5.0)
bonjour-py (0.3)
botocore (1.5.34)
bottle (0.12.13)
certifi (2017.7.27.1)
chardet (3.0.4)
click (5.1)
colorama (0.3.9)
docutils (0.13.1)
ecdsa (0.13)
esptool (2.0b2)
futures (3.0.5)
idna (2.6)
jmespath (0.9.2)
lockfile (0.12.2)
macholib (1.5.1)
matplotlib (1.3.1)
modulegraph (0.10.4)
numpy (1.8.0rc1)
pip (9.0.1)
platformio (3.4.1)
py2app (0.7.3)
pyaes (1.6.0)
pyasn1 (0.2.3)
pyobjc-core (2.5.1)
pyobjc-framework-Accounts (2.5.1)
pyobjc-framework-AddressBook (2.5.1)
pyobjc-framework-AppleScriptKit (2.5.1)
pyobjc-framework-AppleScriptObjC (2.5.1)
pyobjc-framework-Automator (2.5.1)
pyobjc-framework-CFNetwork (2.5.1)
pyobjc-framework-Cocoa (2.5.1)
pyobjc-framework-Collaboration (2.5.1)
pyobjc-framework-CoreData (2.5.1)
pyobjc-framework-CoreLocation (2.5.1)
pyobjc-framework-CoreText (2.5.1)
pyobjc-framework-DictionaryServices (2.5.1)
pyobjc-framework-EventKit (2.5.1)
pyobjc-framework-ExceptionHandling (2.5.1)
pyobjc-framework-FSEvents (2.5.1)
pyobjc-framework-InputMethodKit (2.5.1)
pyobjc-framework-InstallerPlugins (2.5.1)
pyobjc-framework-InstantMessage (2.5.1)
pyobjc-framework-LatentSemanticMapping (2.5.1)
pyobjc-framework-LaunchServices (2.5.1)
pyobjc-framework-Message (2.5.1)
pyobjc-framework-OpenDirectory (2.5.1)
pyobjc-framework-PreferencePanes (2.5.1)
pyobjc-framework-PubSub (2.5.1)
pyobjc-framework-QTKit (2.5.1)
pyobjc-framework-Quartz (2.5.1)
pyobjc-framework-ScreenSaver (2.5.1)
pyobjc-framework-ScriptingBridge (2.5.1)
pyobjc-framework-SearchKit (2.5.1)
pyobjc-framework-ServiceManagement (2.5.1)
pyobjc-framework-Social (2.5.1)
pyobjc-framework-SyncServices (2.5.1)
pyobjc-framework-SystemConfiguration (2.5.1)
pyobjc-framework-WebKit (2.5.1)
pyOpenSSL (0.13.1)
pyparsing (2.0.1)
pyserial (3.4)
python-dateutil (2.6.1)
pytz (2013.7)
PyYAML (3.12)
requests (2.18.4)
rsa (3.4.2)
s3transfer (0.1.10)
scipy (0.13.0b1)
semantic-version (2.6.0)
setuptools (18.5)
six (1.10.0)
urllib3 (1.22)
wheel (0.29.0)
xattr (0.6.4)
zope.interface (4.1.1)

This not correct or not work:

echo %PATH%

This correct:

echo $PATH
/usr/local/bin:/usr/bin:/bin:/usr/sbin:/sbin:/Applications/Server.app/Contents/ServerRoot/usr/bin:/Applications/Server.app/Contents/ServerRoot/usr/sbin:/usr/local/CrossPack-AVR/bin:/Applications/Wireshark.app/Contents/MacOS


#11

I had Python 2.7, and a slightly out of date version of pip. I’m not at that machine now, and now that I’ve removed Python and pip, I can’t get you the list.

I’ll see if I can recreate the situation later today.


#12

Perhaps this will also be useful:

~/.platformio/penv/bin/platformio home
PlatformIO Plus (https://pioplus.com) v0.10.9
Error: Traceback (most recent call last):
File “main.py”, line 128, in main.main
File “/Library/Python/2.7/site-packages/click/core.py”, line 700, in call
return self.main(*args, **kwargs)
File “/Library/Python/2.7/site-packages/click/core.py”, line 680, in main
rv = self.invoke(ctx)
File “/Library/Python/2.7/site-packages/click/core.py”, line 1027, in invoke
return _process_result(sub_ctx.command.invoke(sub_ctx))
File “/Library/Python/2.7/site-packages/click/core.py”, line 873, in invoke
return ctx.invoke(self.callback, **ctx.params)
File “/Library/Python/2.7/site-packages/click/core.py”, line 508, in invoke
return callback(*args, **kwargs)
File “cmd_home.py”, line 449, in cmd_home.cli
File “/Library/Python/2.7/site-packages/platformio/managers/core.py”, line 74, in get_core_package_dir
assert name in CORE_PACKAGES
AssertionError

============================================================

An unexpected error occurred. Further steps:

  • Verify that you have the latest version of PlatformIO using
    pip install -U platformio command

============================================================


#13

Same Problem here, and this is the error I get when running platformio home

➜ air_quality platformio home
Traceback (most recent call last):
File “main.py”, line 17, in init main
File “cmd_home.py”, line 15, in init cmd_home
ImportError: No module named core


#14

See http://docs.platformio.org/en/latest/faq.html#multiple-pio-cores-in-a-system

  1. Please remove old PIO Core from a system.
  2. Try to remove %HOME_DIR%/.platformio/penv folder and restart IDE

P.S: @alvinsunyixiao do you also have a global PIO Core?


#15

I used to have one but I did follow the guide to uninstall the global PIO Core.
It is just platformio home that throws the error.
platformio build & paltformio run work as expected


#16

Could you remove ~/.platformio/penv folder and restart VSCode? Does it work now?


#17

I am using atom editor. I tried to remove the entire ~/.platformio multiple times and reinstalled the pio packages. No change.


#18

Thanks, it helped:

  1. I deleted the PIO Core:

sudo pip uninstall platformio

  1. Off -> On -> settings:

Menu PlatformIO: Settings > PlatformIO IDE > Use built-in PlatformIO Core

  1. Restart ATOM
    Now everything works!

#20

I have the same issue, which is patched by running sudo atom in terminal. It is weird, as the first time I ran PlatformIO it went without troubles. Now, the home screen loads if sudo, but I cannot login (Bad credentials??) and sometimes throws other errors.
(Running under ElementaryOS, based on Debian)


#21

I was having the same issue with VScode. This how I fix it:

  • uninstalled PIO core:

sudo pip uninstall platformio

  • deleted PIO settings:

rm -rf ~/.platformio/

  • Restarted
  • Give web permission to PIOPLUS to have inbound traffic (it shows a popup on mac)