Error on first run of IDE (VSCode): Failed building wheel for netifaces

I’m currently trying to install the PlatformIO IDE for VSCode to try it out. It looks promising so far!

I originally managed to install the extension and its dependencies without issue, whereupon I stumbled across this issue. My first instinct was to uninstall and reinstall the extension. As expected, uninstalling worked without issue; however, upon reinstallation, I was greeted by this error:

I’ve tried rebooting, deleting the folder in my home directory, uninstalling the extension, etc. and it persists. I would try installing PlatformIO Core manually to see if it gave me a better message, but it requires Python2.7 on the PATH and I don’t want to interfere with my Python3 installation. If PlatformIO works without that environment configuration and it would be useful, I can try installing it by hand.

The mentioned directory in my temp directory doesn’t exist by the time this message is displayed and I’m not aware of other locations I should be looking for logs/context. I’m slightly suspicious of the fact that there’s an ellipsized path in the middle of a code snippet, but I assume there’s a layer of indirection I don’t see.

Windows 10 1703 (15063.786)

Any suggestions here?


Please restart IDE, we fixed this issue

Thanks for the quick fix! That worked, now I’m at least back to where I was before. I posted about my subsequent issue here: Can't get PIO to work, Home doesn't want to load - #21 by WasabiFan