PlatformIO Community

WRover kit - Setting Dual RS232-HS (Interface 0) and Interface 1

I got JTAG debugging to work fine. I used Zadig to set Interface 0 to the recommended WinUSB (v6xxxxx) driver with no problem. After that JTAG debugging worked! My problem is somehow I clobbered the Interface 1 driver and my serial port doesn’t work now. Any suggestions on how I can reset my Interface 1 driver back to the serial port? It seems there is no simple way to set it back.

Thank you for any help!

David Wood

I’m just reading posts on this subject, and this other post seems to have a note on your issue. Not sure, but worth a shot:

PS.

In case that other channel (channel 1 in case of wrover-kit) is not detected as com port (used by esptool for flashing),
you must enable the VCP mode on channel 1, this way:

1. On device manager, right click on “USB Serial Converter B” - >Properties ->Advanced
2. Select “Load VCP” then click OK.

vcp

Then, the FT2232 channel 2 should be detected as Com Port on device manager:

The advanced tab is not available - it is not possible to choose “Load VCP”
How can I select this ?
image

The above post shows “Advanced” in the USB device “USB Serial Converter B”, not in the COM port device.

But since you thus also showed that you already have the COM port device, it shouldn’t be necessary to change anything.

:grinning: - thank you very much for enlightening me. I had a problem similar to the above. It works now. I don’t know why - maybe a reboot of my PC or the recent windows update.