PlatformIO Community

The terminal shell path "platformio" does not exist

Upon a fresh install of vscode and pio I’m getting this error when trying to build or upload to a mega2560. I’m a Debian user. Thanks

Have you searched in the forum if anybody else has encountered the same problem?

1 Like

Hint: Platformio does not Run after VSCode update

1 Like

I have searched the forums and found no adequate answer. Thanks for your reply, I will now read the link you posted :slight_smile:

I tried deleting the ~.plaformio folder with no positive result. How would I go about installing a previous version of vscode?

Now I don’t know how to uninstall code 1.37. Any hint?

If I’m not mistaken, the process is as follows (haven’t tried it myself):

How do I delete the current installation? Thanks

Alright, got it, just used synaptic. Now let’s try installing 1.36

What exact command do you run? I just saw this is fresh and I am getting the exact same error and doesnt work even if I reinstall everything…
What command did you use to delete current installation, im not sure what you mean by synaptic? is it the snap command?

I used synaptic package manage to uninstall v 1.37. Then by dpkg -i I installed code v.1.36 and now it’s working like a charm. Hope this helps

Now I’m getting errors when uploading…

Connecting to programmer: .avrdude: butterfly_recv(): programmer is not responding

avrdude: butterfly_recv(): programmer is not responding

I just installed v.1.36 and it worked… I used the Ubuntu Software to uninstall Visual Studio Code then downloaded .deb file from here: https://code.visualstudio.com/updates/v1_36

Note: If you feel up to it, please retest v1.82 of the PlatformIO VSCode extension with VSCode 1.37, as a temporary workaround has been put in place, which appears to be working for some people. I for one can confirm it works on Manjaro (Arch) linux and KUbuntu.

Update: It seems a patch has been committed to undo the change causing this issue, which will show up soon in a recovery build of VSCode 1.37. Later Update: It will be included in the 1.37.1 build, which is expected to be released later in the week. Thanks to Alex on the VSCode team for fixing it so soon, and Daniel for the release info.

On Debian (and derivatives like Ubuntu), to remove VSCode:
sudo apt remove code

To install VSCode 1.36.1:
sudo apt install code=1.36.1*

This is assuming you installed the deb package, and not via the snap package. If you didn’t, you may want to look at the instructions regarding installing the repository and code signing keys.

If you’ve installed via the snap package, I think you’re out of luck, as the VSCode team doesn’t appear to have set up release channels and versions for the snaps.

1 Like