Termux platformio

Hi all. Faced with this problem: when starting a compilation, PIO cannot find the avr-g++ compiler that it installed with the atmelavr dependency. As I understand it, there is no environment variable to reference this compiler.
How can this be solved, can you tell me please?

The problem is similar to the one in the thread: *error: sh1: avr-gcc no such file or directory(Error no.127)*

Does ~/.platformio/packages/toolchain-atmelavr/bin/avr-g++ exist? Is it executable on the shell with --version at the version?

thanks for your answer.
Tried to call avr-g++:
image

“Required file not found”, hm… Maybe that’s a really weird way of saying that a library / .so file is not installed.

Does this system have the ldd command? What’s the result of ldd ./avr-g++?

Further, what’s the output of uname -a?

Thanks for your help!
Screenshot_20230104_043921_com.termux

Screenshot_20230104_043812_com.termux

grafik

That’s not looking good at all. Your phone is of the AArch64 architecture but this (or, all?) Android system seem to be having some other architecture that doesn’t have the /lib/ld-linux-aarch64.so.1 main linker/ interpeter file. Per this the linker is /system/bin/linker64 instead.

This means that out of the box, the toolchain binaries uploaded for Linux AArch64 by PlatformIO will not work on Android systems – not too suprising for me because the AArch64 builds have like a 64-bit Raspberry Pi in mind.

Does /system/bin/linker64 exist on your system? Can it run the file, e.g.,

/system/bin/linker64 ~/.platformio/packages/toolchain-atmelavr/bin/avr-g++ --version

?