Serial Monitor Port

Hi, I’m using a USBTiny to upload the code to my mega2560, i do it like this in platformio.ini and it uploads just fine.

platform = atmelavr
board = megaatmega2560
framework = arduino
upload_protocol = usbtiny
upload_flags = -e

But can’t find the device on Serial Monitor device list.
Using a Macbook and new to Platformio

Is the USBTiny supposed to be a USB-UART converter? Do you have a link where you bought the programmer?

Yes, I bought it from AliExpress.

This is just an ISP Programmer, you can flash the firmware to it but it not see the UART output on the board (which is also on different pins). So that’s not possible with hardware. That’s what USB-UART converter is for (e.g. FTDI based ones)

Do you have the your Arduino Mega connected via USB, too? The FTDI on the board should show up then. When you burn the bootloader on your Arduino Mega via the ISP programmer and Arduino IDE, you shouldn’t need an ISP programmer at all… just the board and the USB cable. Why do you want to use an ISP programmer in the first place?

1 Like

Oh ok then, I’m using a ISP because my 13" Macbook Late 2008 with the Catalina patcher doesn’t seem to work with the Arduino Uno, Mega, Nano directly, it does with nodemcu(esp8266)… Some sort of a driver issue that i lost hours trying to figure it out but can’t find nothing online, I’ve tried different drivers but nothing.

Yes, i’ve tried different cables, USB ports… I’m sure the boards are working, because on a Windows machine works just fine without ISP programmer.

Then you should primarily work on restoring working USB-CDC drivers in your system. The NodeMCU likely works because it uses a different USB-UART chip (like CH340G) and thus a different extra-installed driver is used.

This reminds me of the Catalina 10.15.4 topic, maybe you can find some clues there.

1 Like