Catalina 10.15.4

I had PlatformIO working fine with Catalina but this week I upgraded to v10.15.4 and now I can’t program either

Wemos D1 Minis
A fatal error occurred: Timed out waiting for packet header
*** [upload] Error 2

Arduino Uno
avrdude: stk500_recv(): programmer is not responding
avrdude: stk500_getsync() attempt 1 of 10: not in sync: resp=0x00
avrdude: stk500_recv(): programmer is not responding
avrdude: stk500_getsync() attempt 2 of 10: not in sync: resp=0x00

These boards were working last week, same problem if I use a different USB port

I can’t try on my Windows PC as the hard drive has decided to die!

Has anyone got this working on Catalina 10.15.4 or any ideas to help.

Many thanks

Both serial uploaders have stopped working? That’s really odd. Did you previously do any modifications to the USB serial drivers that were somehow overwritten with the update? Seems like a botched kernel driver to me.

I think I had installed another driver previously. I deleted SiLabsUSBDriver.kext from /library/extensions and now the wemos is working but the uno still has the same problem.

Then there’s still got to be some other kernel driver involved which shouldn’t be there. Maybe you can use the utilities listed here to check which USB serial driver is responsible for the Uno’s serial (or anything suspicious loaded module)

Using kextstat | grep usb I can see the following extensions are loaded by default

25 6 0xffffff7f80d68000 0xe000 0xe000 (1.0) A9FB7951-7658-34C4-9A44-0B6DBE6F7F78 <6 5 3 1>
75 1 0xffffff7f81be0000 0x58000 0x58000 (1.2) 08964881-BCC5-3A07-B3CA-DF5B3512B740 <27 25 12 8 7 6 5 3 1>
76 0 0xffffff7f81d0f000 0x35000 0x35000 (1.2) 5B0343A2-9C4B-3A81-81C3-03601B394CED <75 27 25 13 12 8 7 6 5 3 1>
91 0 0xffffff7f81699000 0x8000 0x8000 (1.2) 01583714-3EC3-3816-8811-0E5BBDBAF768 <27 25 7 6 5 3 1>
92 0 0xffffff7f81a8e000 0x8000 0x8000 (5.0.0) DF9504F6-87C7-3849-B79D-DBADAEF9980E <27 7 6 5 3 1>
98 1 0xffffff7f816a1000 0xc000 0xc000 (1.2) 3C7286E3-B2FF-3B64-8D52-BCE216BADFF5 <49 27 25 6 5 3 1>

and these additional ones when the Arduino is plugged in

188 2 0xffffff7f83e68000 0x7000 0x7000 (5.0.0) 6E1F794B-2A9F-35F1-949B-FD3D3B31F6D6 <92 91 27 6 5 3 1>
189 1 0xffffff7f83e6f000 0x6000 0x6000 (6.0.0) 74754E61-818A-344A-B471-5F1F5F892814 <68 27 6 5 3 1>
190 0 0xffffff7f83e75000 0x8000 0x8000 (5.0.0) 676B2182-F5BC-3837-9319-8C1C225535CA <189 188 92 91 68 27 6 5 3 1>
191 0 0xffffff7f83e7d000 0xc000 0xc000 (5.0.0) D3D4F198-4D47-34B7-A49E-B1A4B5E9732E <188 92 27 26 18 6 5 3 1>

When the wemos is plugged in this appears

192 0 0xffffff7f83e68000 0x5000 0x5000 com.wch.usbserial (1) AD765268-B76B-3619-A05F-DA24C7F8F230 <68 59 5 3>

I’m not sure what else to check here.

Hm I’m no Mac / Darwin kernel expert which would be able to help much further I think :/.

There are similiar reports of having to re-install USB drivers from this issue: SOLVED [Bug] macOS 10.15 Catalina — Upload fails · Issue #366 · adafruit/Adafruit_nRF52_Arduino · GitHub

But I’m not sure what may have changed in your particular system… The standard apple driver seems to be loaded ( for the Uno.

Do you have a genuine Uno (aka a ATMega16u2 as USB-serial chip) or one with CH340G? There is a reference (In case you are having problems with MacOS Mojave and CH340 USB Drivers - Installation & Troubleshooting - Arduino Forum) which says to remove a particular driver in that case.

The output of kextstat indicates that you have the Apple USB CDC driver (good) and the WCH custom driver (bad) installed.

The USB CDC driver implements the USB-to-Serial protocol as defined by the USB standard. This protocol is used by the auxiliary ATMEL MEGA16U2 chip on the Arduino Uno board.

The WCH driver is from the Chinese manufacturer of the CH340G USB-to-serial chip. It is often found on ESP32 boards. I recommend to uninstall this driver as newer macOS versions come with an Apple driver for this chip (driver is found at /System/Library/DriverExtensions/DriverKit.AppleUSBCHCOM.dext).

For the uninstallation, see:

After reading the thread again, I’m not sure my instructions will help as your WEMOS board with the CH340G seems to be working by now. (They shouldn’t hurt either.)

The Arduino Uno uses the USB CDC drivers. It’s not possible to reinstall these. They are at the core of the Mac’s USB implementation.

And neither of the boards needs the SiLabs drivers. They are for yet another USB-to-serial chip.

Try to use a different USB cable and to unplug all other devices, especially those on the same USB port / hub.

I haven’t upgraded to Catalina 10.15.4 yet. But I haven’t heard of any Arduino Uno problems with it either.

My Windows PC is now fixed and I tried the Uno on that and it failed too. I was looking for another USB cable and found another Uno, tried it and that works straight away so it looks like my Uno is duff despite the leds coming on, it appearing in the device list and being able to get board info in the arduino ide.

The new Uno also works on my Mac so there are no problems with it now, it was just bad timing and a duff driver installed.

I can’t remember what I was doing with it last time it worked but I see there are some useful pages to try and resurrect it using the instructions there.

Thanks for your help and stay safe.