Seeeduino XIAO uploading problem

Hello, this problem has been discussed lot on Seeeduino forum, but I have not got solution.
I cannot upload any code to XIAO using PlatformIO.
My XIAO is USB connected and I think it is in bootloader mode, because because the yellow led is slowly blinking. My Windows desktop sees the XIAO (COM18) and as E-drive that has 3 files, so drives should be ok. But uploading fails to avrdude time/out error (-1).
PlatformIO shows the upload protocol as jtag2updi, but XIAO supports for example sam-ba and jlink.
I have tried to change the upload to to sam-ba setting the following line to platform.ini
update_protocol = sam-ba

but PlatformIO still tries to use jtag2updi ? How can I change PlatformIO to use the XIAO supported protocols ?
I cannot upload the sketch using Arduino IDE also (the same protocol error)

Then you have not properly selected the active project, seems to be pointing at an older Arduino AVR project then. See Can’t upload code to esp8266

Try using “upload_protocol” instead maybe?

I am facing the same problem. XIAO is truly a groundbreaking products given its size vs cost. However, the bootloader issues are making me doubt its reliability in the field. For me as well, the programming is a 50-50 chance thing. Sometimes it works, sometimes it doesnt !

Do you know if its possible to replace the current bootloader with a more stable one? Like the one used in Arduino (optiboot) or something?

Hi, I am working with Arduino Nano Every and XIAO projects, and when I learned that I have to change environment (using the “camera” looking icon in the task bar), Platform IO works fine with XIAO. In my platform.ini I have setting: upload_protocol = sam-ba while Nano uses the default upload protocol.
Have you tried it ?