PlatformIO Community

PlatformIO > Libraries > Updates not working after updating to 5.x

Hi all, my first post here.

I am using VS Code + PlatformIO and everything worked well until yesterday when PlatformIO was updated to:

PlatformIO IDE: 2.1.3
Core 5.0.1
Home: 3.3.0

But here is what happens now if I click on: PlatformIO > Libraries > Updates:

PIO_Core_Call_Error

I clicked PlatformIO > Update All before clicking PlatformIO > Libraries > Updates and there is the result of Update All in the terminal window - that contrib-pysite error is the only error when running Update All.

I am not sure which versions of PlatformIO extension, PlatformIO Core and PlatformIO Home were installed until yesterday (Is there a way to check that information in some .log file?) but everything was up to date on 12 July 2020 and everything worked well.

The projects still work well, Libraries > Update is the only thing that stopped working.

1 Like

As per https://github.com/platformio/platformio-core/issues/3700, that error relates to you using Python 3.9, which is not yet compatible.

For the other library update error, see the other thread: Library update issue still unanswered. You need a more recent version of the PlatformIO core.

Greyed out update buttons after that are still subject to being fixed by @ivankravets (per PlatformIO IDE 2.0 for VSCode 🚀). According to this report it’s still happening.

I don’t have Python 3.x installed and 3.x version was never installed on this computer. I am using Python 2.7

I didn’t notice any greyed out update buttons, the only problem are a bunch off errors after clicking on PlatformIO > Libraries > Updates as in the upper right part of the screenshot from my first post.

Is there a log file where I could check which versions of PlatformIO extension, PlatformIO Core and PlatformIO Home were installed before the last update?

Thank you very much for the reply!

Regards

Since, as I said, I don’t have Python 3.x installed at all and I already have the most recent version of PlatformIO core - seems as I can only wait for the updates or downgrade to the older version of PlatformIO :-/

If I read the version number for contrib-pysite correctly, 2.37.191020 should mean that it’s for Python 3.7. Can you open a PIO terminal and post the output of pio system info?

Yes, you are right, the output is:

Python 3.7.7-final.0

But I’ve never installed Python 3.x, the output from python --version in cmd is:

Python 2.7.15

On the other hand, the same command when invoked from PlatformIO Core CLI results in:

Python 3.7.7

Now I see there is python3 folder in:

C:\Users\Username\.platformio

and I can see it was created yesterday during update of PlatformIO. And by running $env:path I can see the path to python3 is added in front of the path variable when using PlatformIO Core CLI, this is the beginning of path variable:

C:\Users\Username\.platformio\penv\Scripts;C:\Users\Username\.platformio\penv;C:\Users\Username\.platformio\python3;C:\Python27\;C:\Python27\Scripts;

Does it mean PlatformIO installed local version of Python 3.x with which itself (PlatformIO) doesn’t work? What could I have done to prevent that? I didn’t have any control of the process of updating.

BTW, I am using Windows 10.

It is definitively a bug. I’ve found that board folders which shouldn’t are being created in .pio\libdeps

For example, here is the .pio\libdeps folder structure of one of my projects (remember, before the update everything worked well):

libdeps_folder

and here is the corresponding platformio.ini file:

[env:myboard]
platform = espressif8266
board = esp12e
build_flags = -Wl,-Teagle.flash.4m1m.ld
framework = arduino
lib_deps =
	ESP Async WebServer
	ESPAsyncTCP
monitor_speed = 115200
upload_speed = 921600

When I deleted these folders marked with “?” they still kept recreating - seemed as random board folders from other projects’ libdeps were created inside every project’s libdeps folder. Then I deleted all .pio folders and they were recreated correctly but as soon as I try:

PIO Home > Libraries > Installed > Updates

there are Libraries: Updates errors like in the screenshot from my 1st post and random board folders which should’t exist under projects that are not using these boards are starting to show again.

Interestingly, if I try just:

PIO Home > Libraries > Updates

then there aren’t any errors.

Such things never happened before the update.

As for the “error”:

Updating platformio/contrib-pysite 2.37.191020 @ ~2.37.0 [Incompatible 2.39.201019]

That isn’t an error and that doesn’t mean I am using Python 3.9 - what that means is I am using Python 3.7 and there is an update for the version 3.9 but update script knows that update wouldn’t work with Python 3.7 so there is the note it will not be installed.

Yes, thanks. We will fix it soon.

1 Like

Fixed in the latest PlatformIO Core Dev version. Please open PlatformIO Core CLI and type pio upgrade --dev. Restart VSCode. Does it work now?

2 Likes

Sorry, I see your post only now. As I can see the bug fix has already been incorporated in version 5.0.2

Now everything works well.

Regards

i been check each and lastest date seem not help me. i did pio upgrade -dev and restart did not help. see screenshoot

version problem

I’m using the exact same Core and Home version as you and updating the libraries is no problem for me in the GUI (which is the problem as described in the first post).

grafik

grafik

Can you show the exact error message that you’re having and procedure to get there?

Hi, I have the same issue on MacOS (10.15.7) with VS Code (1.51.1) and PIO (5.0.4a1).

Screenshot 2020-11-12 at 18.40.18

Any clue what this is related to?

It means that the new version, 2.39.201019 has some incompatibilities with your current installed version, 2.38.201019, so has not been updated.

I see exactly the same message when I run pio update – so far, I haven’t had any problems.

Cheers,
Norm.

Please state what exact issue! The post above talks about 2 things, getting an error when looking at library updates and an “error” regarding the contrib-pysite.

The “error” in contrib-pysite is expected as I have already linked above. You’re running Python 3.8 so they right contrib-pysite package is 2.38.x. Version 2.39.x is for Python 3.9 which you don’t seem to have installed. This “incompatibility” is wanted and is perfectly fine. For Python 3.8 version, the package is just updated to the latest 2.38.x version.

1 Like

Came here with my google-warrior skills, for:
Updating platformio/contrib-pysite 2.37.191020 @ ~2.37.0 [Incompatible 2.39.201019]

Saw the answer in first post, thank you all, felt like I should at least include more data for the future search ninjas…

1 Like