PlatformIO in DevContainer uses the wrong slashes when creating a new project

Hi there,

i have a problem when i create new projects with the PlatformIO IDE inside a Docker DevContainer. First of all my setup:
On host machine:

  • Windows 10
  • Docker version 24.0.2
  • VSCode 1.80.2
    Inside the container:
  • Ubuntu 22.04 LTS
  • PlatformIO 3.3.1

So when i create a new project in PIO i can choose the folder as usual. All the folders of the Ubuntu OS are listed as we know. So i go into some random folder and create my project there. Usually, PIO automatically changes the VSCode working folder to the new project folder. This is not happening in my devcontainer. Instead, PIO just stays open on the starting screen.
No problem so far, but when i try to open that new created folder i can see that PIO used '' instead of ‘/’ in its path, so there is a new folder in the Ubuntu machine which looks like /‘root\workdir\projectName’/ or wherever you try to save your folder. I can’t access it with PIO because it says the path does not exist. I can access the folder with the terminal and even copy all of the files and folders. When i copy everything in a new folder with a “legal” name, without the backslashes, then PIO works just fine in the new folder.
I try to create a PIO project with the STM32 framework for the bluepill controller.
I tried and tried, but i have no idea why PIO is using the '' instead of ‘/’. Is there a setting which slash to use? Or do you have any other suggestions what the problem could be?

Looking forward to hear from you :slight_smile:

If the PlatformIO VSCode extension or core is not correctly intereacting with the DevContainer extension, please file a bug in and provide minimal test project files + reproduction instructions.

Last time someone had problem with DevContainer usage in a project, the easiest solution was to not use DevContainer, which does not apply here though of course.

Thanks for the quick response. I filed an issue in the repo. Here is the ticket if someone needs it Wrong slash gets used when creating new projects in DevContainer · Issue #3789 · platformio/platformio-vscode-ide · GitHub