PlatformIO Community

Platformio-ide freezes atom during installation

I’m using atom on Arch Linux. When installing platformio-ide via the package installer integrated into atom the entire atom editor freezes after a couple of seconds. After a short while a dialog pops up suggesting to force close the not responsive editor or wait.
The only way to get atom running again is to manually remove the platformio-ide directory in ~/.atom/packages .
Unfortunately I’m too new in this business to find atom log files.
Running atom with --log-file some-name does not even create a log file.
Running atom -f doesn’t create any output either.

Anyone out there who could give me some advice?
Thanks in advance!

2 Likes

Follow-up if someone is still interested:

Looking into electron’s console log revealed that there were package dependencies missing which (apparently) were not installed automatically.

I removed platformio-ide:

apm deinstall platformio-ide

and then installed all the missing dependencies in one step:

apm install build platformio-ide-terminal platformio-ide-debugger autocomplete-clang linter-gcc2 language-ini tool-bar

then I installed platformio-ide again

apm install platformio-ide

After relaunching atom it automatically began to install “platformio core” and complained abount “platformio-ide-terminal” to require rebuild which I did. It also asked me to restart Atom.

After the second relaunch Atom continues to show the well known pop-up, here with the message: “PlatformIO IDE has been successfully installed! Please restart Atom to apply the changes.”

This exact message continues to appear independently on how often Atom is restarted.

Suggestions welcome!

When I have time again I will post if platformio-ide is actually working.

Side notes:

  • When doing the above from within Atom rather than from the command line, Atom still freezes when installing “platformio-ide” although the missing dependencies are installed!
  • When Atom was freezing (see first post) other electron apps like rocketchat-desktop frooze, too!

I am currently getting the same error on install, but on the Windows 10 platform. I have removed Atom and reinstalled, and each time it appears to function fine until I install PlatformIO, at which point I also recieve the “Program Unresponsive” dialogue.

Follow-up (2020-06-17T22:00:00Z):

On an freshly installed Ubuntu you can neither install platformio-ide via cli nor from within Atom. Atom will always freeze.

With the workaround of installing dependant packages and platfromio-ide with apm from the command line directly, I got Atom to run on my Arch Linux machine, yet Atom does not show the PlatformIO home screen. There are no error messages. Neither Atom pop-ups nor in the developer tools console (CTRL-SHIFT-I).

Side note:

In the package dependencies above “busy-signal” is missing:

apm install build platformio-ide-terminal platformio-ide-debugger autocomplete-clang linter-gcc2 language-ini tool-bar busy-signal

Partly resolved by downgrading to 2.6.0 (see this post):

I had to do the installation process twice, since atom was very quick in auto updating paltformio-ide to 2.7.1

I couldn’t use apm install --check platformio-ide@2.6.0. I had to omit the --check.

1 Like

I think that somewhere you can disable auto-update by editing a certain file. But which one? :exploding_head: If anyone knows, it would be cool to know how!

@akrusen It’s in the package settings for PlatformIO

image

and it seems to be saved to Atom’s config.cson, which is accessible through the ‘File’ menu in the UI.

"*":
  "platformio-ide":
    autoUpdateIDE: false

It’s location on the filesystem is probably different depending on the OS though, on my Windows box it’s in %userprofile%\.atom\. On Linux it’s probably under $HOME/.atom. Have no idea about Mac though.

Ah, very helpful. Thanks!

Found it on the Mac: it’s in ~/.atom/config.cson :bowing_man: