PlatformIO Community

2.7.1 upgrade killed my platformio-ide, and how I fixed it

Lately, my auto-updated Platform IDE caused a permanent hang/freeze of my Atom text editor.

My setup with platform-ide 2.6.0 had been auto-updated to platform-ide 2.7.1, followed by some updating after relaunch. My setup was now unusable.

A temporary fix is at the end of this post.

Events that lead to broken Atom / platformio-ide setup

  • I opened Atom for the first time after weeks (platformio-ide was at 2.6.0)
  • Atom did some upgrading in the background, a notification said “The new updates for PlatformIO IDE have been installed! Please restart Atom to apply the changes”
  • I restarted Atom
  • A very long red warning by installation manager appeared:

Error: File "/Users/myusername/.platformio/.cache/get-platformio-0.3.2.py", line 26 UEsDBBQAAAAIAIFMx1C3BRK2QQAAAEAAAAATAAAAY2VydGlmaS9fX2luaXRfXy <shortened for brevity> 2RztxlOIofzSF60JUK6sjofkagOPfWps0DsKM/8MC1Q3CT245KuKmop51KrYCbiyy1O1FQqA6uTI0dQoPetfuicV1M/+DFv ^ SyntaxError: EOF while scanning triple-quoted string literal"

at /Users/myusername/.atom/packages/platformio-ide/node_modules/platformio-node-helpers/dist/index.js:1:4975 at ChildProcess.c (/Users/myusername/.atom/packages/platformio-ide/node_modules/platformio-node-helpers/dist/index.js:1:4871) at ChildProcess.emit (events.js:194:13) at maybeClose (internal/child_process.js:998:16) at Process.ChildProcess._handle.onexit (internal/child_process.js:265:5)

  • commands for compiling, uploading stopped working
  • after restarts of Atom showed additional “installing” notifications
  • uninstalling and re-installing platformio-ide resulted in the same error message and broken functionality.

An attempt to start from a clean slate lead to a worsening

  • Quit Atom
  • Moved .atom folder to .atombackup
  • Restarted Atom
  • Installed current platformio-ide 2.7.1
  • A process named “atom helper” now takes ~100% of the CPU
  • Atom asked “Editor is not responding. The editor is not responding. Would you like to force close it or just keep waiting?”

It appears this phenomenon is not limited to MacOS.

These steps restored a usable Atom setup

  • disabled auto-update in the Platform IO IDE
  • re-installed platform-ide 2.6.0: apm install platformio-ide@2.6.0
  • restarted Atom

I do hope this is useful to someone. I am happy to give more info if needed.

Great Job.! Worked for me! Thanks a lot!!

@claus.schumacher.kcs I am happy it worked (and thanks for the editing hint — fixed it!)

Thanks for this fix!

Since I’ve been using PlatformIO this is the second time an upgrade has broken things though… I suspect that this new version was only tested on VS Code and not Atom… :frowning:

1 Like

https://github.com/platformio/platformio-atom-ide and https://github.com/platformio/platformio-atom-ide are two separate things. There the issue is already being discussed.