PlatformIO Community

PIO stopped working inside VSCode

I was working with pio inside the vscode for a couple of months and it was perfect. suddenly I found that it doesn’t work today. it does not perform even a single task. PIO home does not open, all icons in below bar are disappeared and when I hit any task, a pop-up appears saying that “command ‘platformio-ide.upload’ not found”. (for example)
I tried reinstalling the extension and also reinstalling the vscode but the problem persists.
I don’t know what to do.

I just found that platformio is in conflict with C/C++ intellisense extension due to last update. It must be a bug. Currently I have disabled the intellisense extension but hope to be fixed soon.
thanks

After disabling that extension I managed to continue my work. But suddenly the problem returned. now I am confused what is the problem.

I’m confused too. Some weird stuff is happening. Everything works nicely on my other machine with Atom though, so perhaps that’s the way to go. It’s not like you have to use VSC, you know :slight_smile:

Is this the official Microsoft extension, or is this a third party one? If you suspect it’s an update (it’s happened before, it’ll most likely happen again) you can override the version installed with an older one, until either Microsoft release another version that isn’t bugged, or PlatformIO works out what’s changed, and does a workaround.

image

I tried out several older versions of PIO but the problem still exists. So it seems that it is not the version. I even tried it in Windows 10 as well as Ubuntu with the same behavior.
The ‘Project tasks’ tab is still empty.
Could anyone help please? Am I alone?:worried:

This is what I have in PIO toolbar:

1

I disappointed with PIO in vscode and decided to install ATOM ide. Surprisingly I realized that it does not work in atom either!!!
What’s going on gyus???
:astonished::astonished::astonished:

Alright for starters and reproduction, what exact VSCode version are you using and what the versions of installed plugins?

1 Like

Not sure why you downgraded the PlatformIO extension if it was a C/C++ IntelliSense conflict… shouldn’t you be downgrading that?

Anywho… I’ve only seen that before when not having a folder open with a platformio.ini … as it’s a bit hard to have project tasks if there are no configured environments. So what’s in your platformio.ini, and workspace/folder structure like?

image

I have installed vscode 1.38.1 and PIO 4.0.3

I have open folders but PIO seems ill-conditioned. Unbelievably I found that platformio.ini is removed from my folder.

2

I can’t do a single job with PIO. I mean that I can’t open a new project anymore and even can’t open the PIO Home screen! when I hit open in PIO, it shows ‘loading…’ and it lasts forever.

I think that the conflict was a misunderstanding because I completely removed the C/C++ intellisense but it didn’t work.

Who did remove http://docs.platformio.org/en/latest/projectconf.html ?

It has been removed automatically. however the source of the problem is not only platformio.ini because without any open folders I should be able to make a new project but as I said I’m not.

I don’t know you managed to remove the Microsoft C/C++ IntelliSense extension as those actions should be blocked automatically by VSCode as you have another extension installed (PlatformIO) which depends on it. A notification comes up straight away if you try to disable or uninstall it.

Your platformio.ini being missing is certainly part of your problem. I don’t know of anything that “deletes it automatically” … I’d be checking the recycle bin to double check it wasn’t deleted accidentally.

Next, try running pio upgrade and pio update ( in that order ) from the terminal, and see if that clears up what ever is stuck with PIO Home.

image

No… PlatformIO depends on C/C++ extension and not on C++ intellisense. I managed to reenable it and nothing was affected.
Anyway, the main problem now is that PlatformIO Home screen never comes up and I can’t init a new project. upgrading and updating also didn’t work.

Apologies… I was thinking of the first line of the description when I wrote that :wink: The C++ Intellisense extension should probably be disabled though, as it clashes with the IntelliSense provided by the C/C++ extension. Plus, since it hasn’t been updated in two years, anything that’s broken (which is quite a few bits and pieces) will remain broken.
image

Anyway, might be worth closing PIO Home, opening the Developer Tools (console), [edit: and then reopening PIO Home] and seeing if there is anything interesting on the console there…

Thanks, peter.
Unfortunately, I’m not familiar with console tool. I’m not sure what to do with it.

Um… see if any error messages come up? And then share a screenshot of what you get? :wink: