Open a pio project,vscode always show" PlatformIO: Loading tasks... "

Hi.
When I use vscode to open the esp32 project created by platform IO, loading tasks always appear under the vscode.How should I solve it?
the followiing picture show this problem.
image

We work on the PlatformIO IDE 3.0 for VSCode, it will have better explanations of the project configuration process.

The reason for this issue is a slow internet connection. PlatformIO downloads project dependencies. If you use a proxy, please disable it and restart VSCode.

Does it work now?

Thank you for your explanation.I completely uninstalled platform IO, and then someone else gave me the offline installation files, and then it ran perfectly.I guess it’s probably because the network connection is too slow in China.

Could you try to disable any proxies and download the following file? What is your download speed?

If I disable VPN, the download speed is infinitely close to zero.The following files,I could not download.

And how about for this link?

yes!But the download speed is too slow.
What is the file I downloaded for?

I had a similar issue when doing a clean install on macOS 10.13. The issue was I had a dependency in the PlatformIO.ini file that was trying to reach gitlab but the machine did not have valid gitlab login credentials stored. I removed the dependency and the loading tasks loop went away. There’s no timeout on waiting for credentials and I don’t recall seeing the username login prompt in VSCODE so check your PlatformIO.ini if you are stuck loading, it tries to download dependencies before you initiate the build process.

I have the same issue where it keeps getting stuck at PlatformIO: Loading Tasks. And this is after I just did a clean install of PIO in VSCODE because of other PIO Core Call errors. I deleted the PIO folder a few times and then uninstalled/reinstalled PIO. That fixed the original problem, but now I keep getting stuck on this loading loop.

The loading loop may be downloading some necessary files.The way I solved the problem was to change the offline installation package.Because the Internet speed is very slow in China.You can try a few more times,.maybe it works again.

I ended up reverting the PlatformIO version to an older one from 6 months ago and the problem went away.

1 Like

Actually, that stopped working too. Any other ideas why sometimes the loading tasks / rebuilding intellisense takes soooooooo long?

Having the same issue here but on a WLS2 Ubuntu on Windows 11 Pro. Tried this but it didn’t help

Does PIO Core CLI work for you? For example,

pio project init --ide vscode

It gets stuck in:

Resolving env dependencies...
Already up-to-date.
Updating metadata for the vscode IDE...

I ran the following and it seems to have fixed the issue:

cd your-platformio-project-directory
~/.platformio/penv/bin/platformio project init --ide vscode 
~/.platformio/penv/bin/platformio run -d .

Hi, I’m having the same problem and i have tried running
pio project init --ide vscode
but this is where it gets stuck:

Copyright (C) Microsoft Corporation. Todos los derechos reservados.

Instale la versión más reciente de PowerShell para obtener nuevas características y mejoras. https://aka.ms/PSWindows

PS C:\Users\ig\Documents\Repos\NCB-1> pio project init --ide vscode
Resolving esp32dev dependencies...

I have deleted the .platformio folder from my computer so it would re-installed itself but to no change.

After a few minutes it finished but with a FAILED result:

PS C:\Users\ig\Documents\Repos\NCB-1> pio project init --ide vscode
Resolving esp32dev dependencies...
Already up-to-date.
Updating metadata for the vscode IDE...
Error: Processing esp32dev (platform: espressif32; board: esp32dev16m; framework: espidf)
------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------

Verbose mode can be enabled via `-v, --verbose` option
CONFIGURATION: https://docs.platformio.org/page/boards/espressif32/esp32dev16m.html
PLATFORM: Espressif 32 (5.2.0) > Espressif ESP32 Dev Module 16MB
HARDWARE: ESP32 240MHz, 320KB RAM, 4MB Flash
DEBUG: Current (cmsis-dap) External (cmsis-dap, esp-bridge, esp-prog, iot-bus-jtag, jlink, minimodule, olimex-arm-usb-ocd, olimex-arm-usb-ocd-h, olimex-arm-usb-tiny-h, olimex-jtag-tiny, tumpa)
PACKAGES: 
 - framework-espidf @ 3.40402.0 (4.4.2) 
 - tool-cmake @ 3.16.4 
 - tool-esptoolpy @ 1.40201.0 (4.2.1)
 - tool-idf @ 1.0.1
 - tool-mconf @ 1.4060000.20190628 (406.0.0)
 - tool-ninja @ 1.9.0
 - toolchain-esp32ulp @ 1.22851.191205 (2.28.51)
 - toolchain-xtensa-esp32 @ 8.4.0+2021r2-patch3
Installing ESP-IDF's Python dependencies
Collecting idf-component-manager~=1.0
  Using cached idf_component_manager-1.1.4-py3-none-any.whl (95 kB)
Collecting six
  Using cached six-1.16.0-py2.py3-none-any.whl (11 kB)
Collecting contextlib2>0.6.0
  Using cached contextlib2-21.6.0-py2.py3-none-any.whl (13 kB)
Collecting future
  Using cached future-0.18.2-py3-none-any.whl
Collecting tqdm<5
  Using cached tqdm-4.64.1-py2.py3-none-any.whl (78 kB)
Collecting requests-toolbelt
  Using cached requests_toolbelt-0.10.1-py2.py3-none-any.whl (54 kB)
Collecting click>=8.0.0
  Using cached click-8.1.3-py3-none-any.whl (96 kB)
Collecting schema
  Using cached schema-0.7.5-py2.py3-none-any.whl (17 kB)
Collecting colorama
  Using cached colorama-0.4.6-py2.py3-none-any.whl (25 kB)
Collecting requests<3
  Using cached requests-2.28.1-py3-none-any.whl (62 kB)
Collecting pyyaml>5.2
  Using cached PyYAML-6.0-cp39-cp39-win_amd64.whl (151 kB)
Collecting urllib3<1.27,>=1.21.1
  Using cached urllib3-1.26.12-py2.py3-none-any.whl (140 kB)
Collecting idna<4,>=2.5
  Using cached idna-3.4-py3-none-any.whl (61 kB)
Collecting charset-normalizer<3,>=2
  Using cached charset_normalizer-2.1.1-py3-none-any.whl (39 kB)
Collecting certifi>=2017.4.17
  Using cached certifi-2022.9.24-py3-none-any.whl (161 kB)
Installing collected packages: urllib3, six, pyyaml, idna, future, contextlib2, colorama, charset-normalizer, certifi, tqdm, schema, requests, click, requests-toolbelt, idf-component-manager
  Attempting uninstall: urllib3
    Found existing installation: urllib3 1.26.12
    Uninstalling urllib3-1.26.12:
      Successfully uninstalled urllib3-1.26.12
  Attempting uninstall: six
    Found existing installation: six 1.16.0
    Uninstalling six-1.16.0:
      Successfully uninstalled six-1.16.0
  Attempting uninstall: pyyaml
    Found existing installation: PyYAML 6.0
    Uninstalling PyYAML-6.0:
      Successfully uninstalled PyYAML-6.0
  Attempting uninstall: idna
    Found existing installation: idna 3.4
    Uninstalling idna-3.4:
      Successfully uninstalled idna-3.4
  Attempting uninstall: future
    Found existing installation: future 0.18.2
    Uninstalling future-0.18.2:
      Successfully uninstalled future-0.18.2
  Attempting uninstall: contextlib2
    Found existing installation: contextlib2 21.6.0
    Uninstalling contextlib2-21.6.0:
      Successfully uninstalled contextlib2-21.6.0
  Attempting uninstall: colorama
    Found existing installation: colorama 0.4.6
    Uninstalling colorama-0.4.6:
      Successfully uninstalled colorama-0.4.6
  Attempting uninstall: charset-normalizer
    Found existing installation: charset-normalizer 2.1.1
    Uninstalling charset-normalizer-2.1.1:
      Successfully uninstalled charset-normalizer-2.1.1
  Attempting uninstall: certifi
    Found existing installation: certifi 2022.9.24
    Uninstalling certifi-2022.9.24:
      Successfully uninstalled certifi-2022.9.24
  Attempting uninstall: tqdm
    Found existing installation: tqdm 4.64.1
    Uninstalling tqdm-4.64.1:
      Successfully uninstalled tqdm-4.64.1
  Attempting uninstall: schema
    Found existing installation: schema 0.7.5
    Uninstalling schema-0.7.5:
      Successfully uninstalled schema-0.7.5
  Attempting uninstall: requests
    Found existing installation: requests 2.28.1
    Uninstalling requests-2.28.1:
      Successfully uninstalled requests-2.28.1
  Attempting uninstall: click
    Found existing installation: click 8.1.3
    Uninstalling click-8.1.3:
      Successfully uninstalled click-8.1.3
  Attempting uninstall: requests-toolbelt
    Found existing installation: requests-toolbelt 0.10.1
    Uninstalling requests-toolbelt-0.10.1:
      Successfully uninstalled requests-toolbelt-0.10.1
  Attempting uninstall: idf-component-manager
    Found existing installation: idf-component-manager 1.1.4
    Uninstalling idf-component-manager-1.1.4:
      Successfully uninstalled idf-component-manager-1.1.4
Successfully installed certifi-2022.9.24 charset-normalizer-2.1.1 click-8.1.3 colorama-0.4.6 contextlib2-21.6.0 future-0.18.2 idf-component-manager-1.1.4 idna-3.4 pyyaml-6.0 requests-2.28.1 requests-toolbelt-0.10.1 schema-0.7.5 six-1.16.0 tqdm-4.64.1 urllib3-1.26.12
Reading CMake configuration...
Error: Couldn't find target config target-__idf_esp_timer-a7ffc6f8bf1ed76651c1.json
============================================================================================================ [FAILED] Took 45.63 seconds

Last saturday it was working fine, but today it just doesn’t work.
I tried upgrading platformio extension too, but still it doesn’t work.

Thanks!, I’ll keep trying some other stuff, will update when I get a success result.

Could you remove the .pio folder from the project and try building again?

I ended up eliminating everything, reseting windows and downloading the repository again.
I also run a “Clean” task and after all that it started working again.
As you can see I kind of paniced a little bit.

Thank you!!