PlatformIO Community

Obsolete PIO Core - Remove multiple PIO Cores from a system

I’m following up on @maxgerhardt’s suggestion to fix this multiple cores error.

I believe that I began getting this error after I installed the latest -dev version of PIO Core in an attempt to resolve a previous problem. Now I get the multiple cores error whenever I build,
but I’ve been unable to resolve it by following the uninstall instruction in the FAQ:

pip uninstall platformio
WARNING: Skipping platformio as it is not installed.

I tried upgrading via PIO Terminal in VSCode:

$ pio upgrade
You’re up-to-date!
PlatformIO 5.1.0 is currently the newest version available.

Then I tried to PIO update, which ran successfully but didn’t affect the multiple cores (and it also reported the same issue). I also ran the PIO Core installer script:

python get-platformio.py

Again, no errors, but no fix. Do I need to remove it manually by deleting this folder?

I’ve searched my hard drive, and no other .platformio folder exists, only this one: C:\Users\Matt.Barney.platformio

My environment is:
Windows 10 Pro 64-bit
VSCode 1.54.1
PIO Core 5.1.0
PIO Home 3.3.3
PIO IDE 2.3.0

Can open a CMD (Windows + R -> cmd.exe) and execute where pio? What path(s) does it report?

Does the file C:\Users\<user>\.platformio\penv\Scripts\pio.exe exist, too? (This is where the built-in core should be)

When you go in VSCode -> Extension side bar -> Cogwheel at PlatformIO extension -> extension settings, is the checkbox for “Use Builtin PIOCore” checked or unchecked?

>where pio

reports: INFO: Could not find files for the given pattern(s).
and I don’t find it in my system or user PATH variables.

Yes, pio.exe exists here: C:\Users\Matt.Barney\.platformio\penv\Scripts\pio.exe

The Builtin PIOCore box is checked:
image

Then I don’t see any duplicate cores.

Do you have any procedure with which you can trigger the “duplicate cores” message? Does it appear when building the same projects twice, or just once on an older project?

Every project seems to trigger the message, even a new, unmodified project: VSCode -> PIO Home -> New Project -> click Build

Also, from the PIO CLI window in VSCode:

$ pio run -h **************************************************************************************************************************************************************************************************************
Obsolete PIO Core v5.1.0 is used (previous was 5.1.1a3)
Please remove multiple PIO Cores from a system:
https://docs.platformio.org/page/faq.html#multiple-platformio-cores-in-a-system


Also tried a verbose build on a new project, but I’m not sure it illuminated anything new:

$ pio run -v **************************************************************************************************************************************************************************************************************
Obsolete PIO Core v5.1.0 is used (previous was 5.1.1a3)
Please remove multiple PIO Cores from a system:
https://docs.platformio.org/page/faq.html#multiple-platformio-cores-in-a-system
************************************************************************************************************************************************************************************************************** Processing mayfly (platform: atmelavr; board: mayfly; framework: arduino) --------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------
CONFIGURATION: https://docs.platformio.org/page/boards/atmelavr/mayfly.html
PLATFORM: Atmel AVR (3.2.0) > EnviroDIY Mayfly
HARDWARE: ATMEGA1284P 8MHz, 16KB RAM, 127KB Flash
DEBUG: Current (simavr) On-board (simavr)
PACKAGES:

  • framework-arduino-avr 5.1.0
  • toolchain-atmelavr 1.70300.191015 (7.3.0)
    LDF: Library Dependency Finder -> http://bit.ly/configure-pio-ldf
    LDF Modes: Finder ~ chain, Compatibility ~ soft
    Found 5 compatible libraries
    Scanning dependencies…
    No dependencies
    Building in release mode
    MethodWrapper([“checkprogsize”], [".pio\build\mayfly\firmware.elf"])
    Advanced Memory Usage is available via “PlatformIO Home > Project Inspect”
    RAM: [ ] 0.1% (used 9 bytes from 16384 bytes)
    Flash: [ ] 0.4% (used 510 bytes from 130048 bytes)
    .pio\build\mayfly\firmware.elf :

section size addr

.data 0 8388864

.text 510 0

.bss 9 8388864

.comment 17 0

.note.gnu.avr.deviceinfo 64 0

.debug_aranges 64 0

.debug_info 2314 0

.debug_abbrev 1873 0

.debug_line 258 0

.debug_str 662 0

Total 5771
======================================================================================== [SUCCESS] Took 0.64 seconds ========================================================================================

Hmm the question is where does it find 5.1.1a3 (which is the latest dev version) and where does it find v5.1.0.

Please restart VSCode and open the PIO Home screen. What does it say in core?

grafik

What does it say when you open a CLI and execute pio --version?

PIO Home screen says 5.1.0
Also from CLI:

$ pio --version
PlatformIO Core, version 5.1.0

Hm I don’t see where the 5.1.1a3 version could be coming from. If the executable isn’t in your system’s PATH.

Otherwise you can try the latest dev core (it has some improvements) by again using the VSCode CLI to execute pio upgrade --dev. Then restart VSCode. Is the version PIO Home now 5.1.1a3 and the error disappears after building a project twice?

OK, confirmed that after pio upgrade --dev, restarting VSC, then PIO Home shows Core 5.1.1a3. Building a project repeatedly succeeds with no PIO Core warning.

What is the recommended way to downgrade, if desired, to the latest stable release after doing this? (pip list (as well as pip uninstall platformio) do not find platformIO. I’m running pip from Windows cmd prompt window.)

I believe that the way I got into the ‘multiple cores’ state (a couple days ago) was:

  1. Troubleshooting a different issue, I decided to try the dev version: pio upgrade --dev
  2. Finished troubleshooting and attempted rollback: pio uninstall platformio
  3. Restart VSCode. Upon startup, its status bar reported PlatformIO Installer: Installing PlatformIO Core
  4. At this point, PIO Home reported that Core was v5.1.0, but any subsequent build reported the ‘multiple PIO Cores’ error.

Have you found a solution? I have the same problem.
How can I downgrade to the latest stable?

Just uninstall PlatformIO completely and reinstall it, that gives you the stable version.