NodeMCU-32s cannot detect WiFi

I had previous issues with a project that my board did not connect to my wifi, after a little while i thought it was corruption due to the connection of my board to my computer using a hub. It turned out it was not the case since i’m now connected directly to my computer. I ran this code:

 *  This sketch demonstrates how to scan WiFi networks.
 *  The API is almost the same as with the WiFi Shield library,
 *  the most obvious difference being the different file you need to include:
#include "WiFi.h"

void setup()

    // Set WiFi to station mode and disconnect from an AP if it was previously connected

    Serial.println("Setup done");

and this is the output i get:

configsip: 0, SPIWP:0xee
mode:DIO, clock div:2
entry 0x400806ac
Setup done

At this point i’m not sure what is the problem, could it be my board that is broken and doesn’t detect the WiFi? I’m living in an appartement building so there should be at least 1 listed below.

But you still have the loop code missing?

void loop()
    Serial.println("scan start");

    // WiFi.scanNetworks will return the number of networks found
    int n = WiFi.scanNetworks();
    Serial.println("scan done");
    if (n == 0) {
        Serial.println("no networks found");
    } else {
        Serial.println(" networks found");
        for (int i = 0; i < n; ++i) {
            // Print SSID and RSSI for each network found
            Serial.print(i + 1);
            Serial.print(": ");
            Serial.print(" (");
            Serial.println((WiFi.encryptionType(i) == WIFI_AUTH_OPEN)?" ":"*");

    // Wait a bit before scanning again

Man I’m such a piece of work ahah, I never realized in the first place that you included a loop() to the initial post! It now prints out some network but not mine, so i guess that a router problem then.

1 Like

Very good that you can scan some networks now. You can usually see your network on your computer or on the phone, right? (No hidden SSID configured). There are also TX power settings in the router (max TX power limited by law per country).

Try to stand the ESP32 upright or at a higher place, to try to get different radiation pattern and antenna directions, or better, close to the router. That should confirm the source of problem as “signal too weak”.

Note that there also dev boards (e.g. the ESP32-WROOM-32U) which have no on-board antenna but a u.FL connector for an external antenna. With a good omnidirectional antenna with a few dBi gain, or a slightly directional antenna, you might get much better results.

I think it really is my router that is messed up, i tried to connect my printer to it once and it doesn’t see it either! i figured out a way using an app on my phone and it seems to work! but now my problem is that i can’t navigate to the IP adress it gives me on my last post:

Is the IP you get from the same subnet your computer is in? Do you see the device in the router’s DHCP leases / devices? (E.g., if your PC is on and your ESP32 is on, that should be fine. If it’s a on a completely different subnet like then there’s a problem.).

You can also try to see if you can ping <ip> your ESP in the commandline.


Yeah thats what i figured out afterward! I connected to the same network and it worked fine ! I can finally play around with the project now!! Thank you for your time !

1 Like