Multiple PIO Cores

Obsolete PIO Core v6.0.2 is used (previous was 6.0.3rc1)
Please remove multiple PIO Cores from a system:

This message started showing today when i use anything in platformio, and when i do what the page says, this is on terminal:
Is it right? Whoudn’t it uninstall all of platformio?

No, the “whole” of PlatformIO would be in C:\Users\<user>\.platformio, it’s “just” deleting the PlatformIO package from the virtual enviornment created with the penv folder therein.

However, it seems then that you have multiple cores installed? The one in .platformio is at 6.0.2. And the 6.0.3rc1 core is where? System-wide? When you open a new regular terminal outside of PlatformIO (Cmd+R → cmd.exe), does pip uninstall platformio try to uninstall a different PlatformIO installation?

I have the same issue as Gabu322, except we are now up to 6.0.3rc2, which I presume is a nightly build which has somehow got into the stable release 6.0.2 I find no evidence of dual cores being active, and have uninstalled etc…

Does the message ever reappear once you build the project again? In the CLI, what does pio system info say?

Hi Max, not building my project, just trying to connect to an RPi remote also running 6.0.2:
pio remote device monitor
************************************************************************Obsolete PIO Core v6.0.2 is used (previous was 6.0.3rc2)
Please remove multiple PIO Cores from a system:

pio system info says:

PlatformIO Core 6.0.2
Python 3.9.10-final.0
System Type windows_amd64
Platform Windows-10
File System Encoding utf-8
Locale Encoding cp1252
PlatformIO Core Directory C:\Users\Mikes 6700K\.platformio
PlatformIO Core Executable C:\Users\Mikes 6700K\.platformio\penv\Scripts\platformio.exe
Python Executable C:\Users\Mikes 6700K\.platformio\penv\Scripts\python.exe
Global Libraries 0
Development Platforms 3
Tools & Toolchains 30

If you open a regular terminal outside VSCode with Windows + R → cmd.exe and execute pip show platformio and pio system info, does it return anything? (Trying to figure out whether there really are 2 cores installed in your system).

nothing returned, had tried that Max, also tried wading through the .platformio\penv\Lib\site-packages\platformio\remote\client scripts :thinking:

Well there really are no double cores installed then there should be no lasting problem. Not sure how you temporarily got 6.0.3rc2 then and are now back to 6.0.2. Did you ever do a pio upgrade --dev in the console or turned on the PlatformIO extension setting for “use latest dev core”?

Max, no, I haven’t played with dev cores, and I have removed the platformio extension for visual studio code and reinstalled, so I don’t believe that is contributing. Should I delete C:\Users\<user>\.platformio ? If so, what precautions should I take?

Yes, remove this folder and restart VSCode. Everything should work.

Ivan, once again, thank you… it worked fine. Hope the Ukraine situation is not weighing too heavily on you, and that NATO countries start showing similar courage to you and Alona and give the Ukraine unrestricted support.


Mike, glad to hear that it helped!

Big THANKS for the kind words and your support! :pray:

Happy coding with PlatformIO! :rocket: