PlatformIO Community

Issue with PlatformIO in Visual Studios

I’m new to Paltformio and visual Studios. I’m trying to work on my Marlin firmware for a 3d printer I built.
Last week Platformio was working fine I was able to make changes and build and save the firmware and now none of the Platformio options are showing up. I have tried uninstalling Platformio, Visual Studios and Python and reinstalling everything and it didn’t solve anything. Some help would be appreciated. Thanks in advance.

You usually get the PlatformIO toolbar at the bottom when you open a folder with the platformio.ini file within. You also get the “alien head” on the left side toolbar.

Are you seeing a platformio.ini file in the opened folder?

Also, if PlatformIO updated, you might need to update your Marlin source too.

HTH

Cheers,
Norm.

Please show a screenshot of what you see in VSCode.

I do have the paltformio.ini file but no toolbar at the bottom and ne alien head on the left. What do you mean by update the marlin source?

image

Is the PlatformIO icon available in the “…” menu on the left sidebar?
Do you have any other projects open in the workspace?

The Platformio icon is not available on the left and I don’t see any other projects open

I mean, download the latest version. Sorry if I wasn’t clear.

Recent changes in PlatformIO and/or Marlin has caused some people problems – solved by getting the latest Marlin sources.

Cheers,
Norm.

I went to the Marlin site and downloaded the latest and opened it up and I’m still seeing the same issue.

Can you show what extensions are installed per

grafik

?

Here are the installed extensions
image

Somehow the PlatformIO extension didn’t activate. Have you restarted VSCode already? If yes, remove the PIO extension again, reinstall and re-open VSCode.

I removed Platformio extension reinstalled it and reopened VSCode and still not working?
I appreciate the help being new to this it’s frustrating because it was working.

What happens when you do a File -> Open Folder and select your Marlin project folder? PlatformIO should activate.

when I open the project folder the project opens but Platformio doesn’t activate.

Go to Help -> Toggle Developer Tools -> Console. Is any error being logged there?

I’m getting the following
image

…very strange. Can you temporarily uninstall the Jupyter Notebook extension in VSCode?

Also go into the VSCode extension settings and make sure the setting

grafik

“Activate Only On Platform IOProject” is turned off.

To uninstall jupyter I had to uninstall Python. I also fixed my platformio settings. I did both and reopened VSCode and the platformio alien head on the side tool bar now appears

Oh wow, Python now really does depend on Jupyter… That hasn’t been the case for long, has it?

grafik

…eh, that’s bad. I recall multiple times here were having a Jupyter (and Anaconda) installation basically destroyed PlatformIO and its Python installation. However as I’ve shown in my previous screenshots I actually also have this extension auto-installed with Python and my PlatformIO extension is working perfectly fine. Do you remember doing anything else to VSCode that might have broke it?

(@ivankravets maybe intersting for you regarding Jupyter.)