PlatformIO Community

First time J-link user. BUT not working

Hi
I have purchased a J-link which I suspect might be a clone but I cannot get it to connect to My chip
I am trying to flash the firmware on an HDMI board using this J-link but I get the error
Failed to connect
cannot establish a connection to target

It would not let me do anything until i updated the firmware which it updated ok

The led blinks from green to red
Attached are photos of the item
I do not know if I need to reflash the firmware or is it a setting

Please can someone help me
Thanks so much in advance
j4

That is far from enough information to be able to tell what is wrong.

  • What platformio.ini are you using?
  • What is the target chip?
  • How did you wire the board to the JLink?
  • How do you power to the target board?

The target chip is tmpm361f10fg
I am using dupont cables

The target board is powered by the j-link
Has anyone reflashed the firmware inside the j-link clone
please
thanks

The Toshiba TMPM361F10FG, ARM Cortex-M3 based, isn’t even supported by PlatformIO, so I assume you’re not using PlatformIO?

The only advice I can give here is check the datasheet of the chip to see where the necessary SWD pins are. SWDIO and SWDCLK are pin number 61 and 62, RESET is number 3.

grafik

Also mind the JLink pinout. Check their wiki regarding Pinout for SWD.

Since you have not shown how your wiring, only

and also not the PCB, I can’t check wether any connections are okay.

Thanks for the reply but I keep getting
Failed to connect
cannot establish a connection to target

The correct drivers are installed

Also can someone explain
what is
jlink Target interface voltage “VIF”

Many Thanks

Please ask that on JLink forums.

Is it possible that someone here can help me please
There are lots of talented people here

Sure, I’ll leave the topic open.

If you have all the wiring correctly regarding the SWD interface (and common GND) of course, it could just be that the JTAG/SWD interface has been disabled on the chip after programming, by burning an internal fuse. This is a very common countermeasure against people trying to dump the firmware off a commercial product for protection of intellectual property. See for example https://www.youtube.com/watch?v=_E0PWQvW-14.

I have been told it is possible to read this chip
Can chips like this go bad
There are no burn marks, liquid damage

Also can someone explain what is jlink Target interface voltage “VIF”

It’s an analog input, intended use is measuring the target power supply voltage. It does not provide power for the target, just measures it.

The J-Link board on the picture is definitely a clone, and Segger actively defends against clones. Considering the low price of the jlink edu mini, what is the point for a clone?
However, if the Segger driver refuses a clone, it writes something like “Faulty device”, and your error message is different. So it’s possible that the reson is not the clone, but faulty wiring, missing target power, or incorrect settings.
Did you test it using the Segger JFlash Lite program for erasing or flashing the target?
What happens, if you test the Jlink adapter using the Jlink Commander or Jlink Configurator?

My edu mini’s response:
SEGGER J-Link Commander V7. 0a (Compiled Apr 16 2021 15:34:05)
DLL version V7.00a, compiled Apr 16 2021 15:32:47

Connecting to J-Link via USB…O.K.
Firmware: J-Link EDU Mini V1 compiled Feb 18 2021 11:25:23
Hardware version: V1.00
S/N: 801026507
License(s): FlashBP, GDB
VTref=3.293V

Type “connect” to establish a target connection, ‘?’ for help
J-Link>

The response of my Jlink edu (similar box to your clone):
SEGGER J-Link Commander V7. 0a (Compiled Apr 16 2021 15:34:05)
DLL version V7.00a, compiled Apr 16 2021 15:32:47

Connecting to J-Link via USB…O.K.
Firmware: J-Link V11 compiled Apr 27 2021 16:36:21
Hardware version: V11.00
S/N: 261006780
License(s): FlashBP, GDB
OEM: SEGGER-EDU
VTref=3.290V

Type “connect” to establish a target connection, ‘?’ for help
J-Link>

Hi
I finally got it to connect. I had to use an old version of J-flash
But when I try to read the chip I get an error
Ram check failed

I have tried to erase the chip same error
I tried using external 3.3v but made no difference

Has anyone experienced this error before
Could the IC chip be bad ?

Try to check a different chip to decide whether the target, or the Jlink is the problem. Do you have a different chip, for example a BluePill (STM32F103C8T6) board?

unfortunately i don’t

HI
I am a first time user of using J-link
I know that I have been sold a J-link clone but have been told it works and read reviews from others that it works
I know the J-link edu is cheap but the edu version doesnt support the chip that i need to program

I have connected it correctly, I think
I am using SWD mode

I want to program a new TMPM361F10FG but i keep getting an error that I have uploaded
I don’t have other development boards to try My J-link clone on but I have a J-link V8 that is also a clone so what I thought is use My v9 J-link to read the J-link V8 firmware
Still get the same error

What am i doing wrong
Please can someone confirm how to wire this
I will really appreciate the help from everyone here
Thanks
20210921_160720

All relevant links to the datasheet and JLink connector have been posted above.

If you don’t post how you have wired it with a schematic and pictures, we can’t help you.

It’s also good to confirm voltages on the chip’s VCC pins.

If your chip is properly connected to the JLink and has proper power but still can’t be flashed, the chip might be defective.

If I take the example of using J-link v9 to read the firmware on the j-link v8
I use swd mode
I have tried different setups

Jlink V8 - vtref pin goes to Vtref - J-link v9
Jlink V8 - swdio pin goes to swdio - J-link v9
Jlink V8 - swclk pin goes to swclk - J-link v9
Jlink V8 -gnd pin goes to gnd- J-link v9

did not connect reset
What I also tried is moving the jumper on the J-link v9 to output 3.3v on pin 2, vout
then I connected this pin to the vtref pin the j-link v8
but did not work

According to this link

It says
VoUT is a 33V voltage output pin.

The user can remove the short-circuit cap inside the device and turn off the 3.3V output.

VTREF is the internal voltage reference, this pin must be connected to the vcC of McU
so does this mean the vtref pin goes to the vtref pin on the other j-link

It means what it says. V_TREF (Voltage Target-Reference) needs to be connected to the voltage that the target is using. In your case 3.3V

Besides that, the target microcontroller must of course be receiving 3.3V too.

Have you also connected nRESET on the JLink connect to (n)RESET on the microcontroller?

Can you supply a schematic of how you connected everything?

i dont have schematics
Can you tell me how you would read the firmware on another jlink using a Jlink v9
please
how would i read this
if i know how you would do it then i can copy it
You are more experienced

After googling i found this
would this solve my issue
https://blog.csdn.net/duan316/article/details/77160782
use google translate