J-Link Ramcheck failed error, first time using J-link

I am a first time user of using J-link
I know that I have been sold a J-link clone but have been told it works and read reviews from others that it works
I know the J-link edu is cheap but the edu version doesnt support the chip that i need to program

I have connected it correctly, I think
I am using SWD mode

I want to program a new TMPM361F10FG but i keep getting an error that I have uploaded
I don’t have other development boards to try My J-link clone on but I have a J-link V8 that is also a clone so what I thought is use My v9 J-link to read the J-link V8 firmware
Still get the same error

What am i doing wrong
Please can someone confirm how to wire this
I will really appreciate the help from everyone here

Please see the previous topic you’ve posted about this: First time J-link user. BUT not working - #6 by maxgerhardt. What advice did they give you on the JLink forums when you asked them about this and showed how you connected the chip to power + JLink? You did that, right? :wink:

The j link forums are paid for so I cannot post there
so i thought i would come here and seek help from the talented people here

I could create the initial account just fine with no company info and no JLink product serial IDs.


Have you tried registering and were rejected?

I read that the forums are paid support

I got approved without paying anything.


Have you tried opening a topic there? The worst they can say is ‘no’.

I dont want to get blocked that is my worry

How can i check My j-link is working
Can I use J-link to read firmware from a router to check for example or can i buy a cheap board to try the j-link on
Ideally if something that involves not buy additional things
or is there a self test that can be done


Any help will really be appreciated

about JTAG, ARM and Tracing in general and describes J -Link and J -Trace 3 When you do this for the first time , Windows will start the Install wizard.


Hi What do you mean

I have asked on the Segger forum but no response as of yet