Endless loop of "Installing:" and "Restart" promt


#1

Hello, i have encountered a problem. I haven’t been using Atom for about 2-3weeks, because i’ve been on vacation.

When i’m now starting Atom the Updating promt appears and it’s trying to update the PlatformIO IDE Core, after this is done it forces me to restart Atom, because nothing within the PlatformIO IDE is working. As soon as i click the green restart Button Atom reboots and the Updating PlatformIO Core loop begins again.

When im uninstalling the PlatformIO IDE within Atom, the updating loop stops, but obviously that’s not a solution. I have installed the lates Version of the IDE 2.1.4, but even after reinstalling it, the updating loop just begins again.

I’m hoping somebody is able to help me. Thanks


#2

Today i also updated the Java Runtime Environment to 10.0.1

Also i tried uninstalling and reinstalling Atom itself. But all the Plugin were afterwards still installed, so i think it wasn’t a real clean reinstallation.

Can somebody tell me how i can open the error terminal, so i can read the eventually logged error while PlatformIO IDE is trying to update. I can’t find the error log on my own

Thanks a lot


#3

I used today an Uninstallation helper tool to clean up all the leftovers of the Atom Installation. Then did a fresh installation of Atom.

First i got an other error message, that Aton can’t find a Dictionary anymore??
And of course after installing PlatformIO IDE i got the permanent loop already meantioned further above.

Is anybody able to tell me how i can troubleshoot this issue?


#4

Hi, i have just tried out of curiousity if PlatformIO IDE works within VSCode.
WELL, i sadly have to admit it’s the same sadly pathetic endless loop of:

  • “Checking PlatformIO Core installation…”
  • “Installling PlatdormIO IDE…”
  • “PlatformIO IDE has been successfully installed! Please reload window” ==> Reload Now

VSCode does reboot, and the ulysses beginns again.

Is there a bug within the PlatformIO IDE? or is my System the Problem, and why did PlatformIO IDE work within Atom about 3 weeks ago flawless?


#5

Extremely weird. Can you try purging every existing PIO installation, in the IDE plugin and in the shell (http://docs.platformio.org/en/latest/faq.html#multiple-pio-cores-in-a-system) and retry? Never seen that before.


#6

Im using Win10 so i cannot really follow the instructions within the FAQ to uninstall the actuall PlatformIO Core.

Do you know a way to see a error log either in Atom or VSCode to comprehend where the actuall failure whilst installing the PlatformIO Core is appearing?


#7

Ahh, oh ok. Shame on me. Either VScode as Atom has its own acces to a Terminal(Windows PowerShell) but in neither of them had the instruction “pip uninstall platformio” any cause to the actual Installing-RestartNow loop.

Does either VSCode or Atom generate somewhere somekind of a error Logfile with whose help it would be possible to determine the error occuring the installation process…??
Or is it possible to somehow acces the Java Error Log to gain knowledge about this total failure??


#8

Is it possible that a poor innocent Space " " in my Win10 Username is causing all those problem with the PlatformIO Core/IDE ???


#9

I’ve just created user with a space in a name using VM Win 10 and everything works well.


#10

Hmmmm, I did create a few minutes ago, as i came home from work, “just” an other user in my Win10 without a space an now it works fine. Atom is running again and there’s no issue with PlatformIO.

Maybe something else trigger this failure, but now I actually have a good reason to do the reinstallation of my OS. Needs to be clean up anyways.

Maybe someone still can tell me how to read something like a error log within Atom, to eventually provide some feedback.


#11

just disable or configure firewall / antivirus. Works for Atom and VSCode. I picked it up to find out.