PlatformIO Community

Could not start PIO Home server

I’m getting this message when I try to open PIO Home from VSCode:
Error: Could not start PIO Home server: Error: timeout

I’m running Windows 10 Pro.

I tried the following sequence, but the result is the same error:
Uninstalled PIO IDE from VSCode.
Uninstalled VSCode.
Uninstalled Python.
Rebooted.
Installed latest VSCode
Installed latest Python
Installed latest PIO extension from VSCode.

This began after I got the ‘multiple cores’ error when compiling a PIO project within VSCode. I successfully did a pip uninstall platformio from the PIO command line inside VSCode. I also deleted ~/.platformio folder.

Well but if you do it within a PIO commandline you will delete the version that the PlatformIO extension is internally already using and probably not the other core which is probably in the system context. Have you originally installed PlatformIO via using pip in a normal shell? You should remove that first. Check with pio system info on the commandline whether it’s still there, or search your harddrive for platformio.

Thank you for your reply, @maxgerhardt. I may have installed PIO using pip some months ago, but am not sure.

I searched my hard drive and found no pio.exe nor platformio.exe. I did find platformio.platformio-ide-2.3.2 under ~\.vscode\extensions. That goes away when I uninstall PIO extension from VSCode, as I would expect, but then after reinstalling the extension, PIO Home still won’t come up.

Also, when I type pip list, PlatformIO is not listed.

What happens when you open a CLI and execut pio home? Is there an error message?

When I click PlatformIO Core CLI, I get the following in the bash window:
$ pio --help
bash: pio: command not found

Similarly, when I click New Terminal and type pio home, I get
$ pio home
bash: pio: command not found

You might need to follow the instructions here to get the shell commands working.

Cheers,
Norm.

Thank you Norm. I added C:\Users\<myUsername>\.platformio\penv\Scripts to my Path in System environment variables and restarted VSCode. I also tried uninstalling and reinstalling the PIO extension, but pio shell commands still don’t work.

If PlatformIO were installed successfully you should have access to PIO commands in the PIO CLI (as linked above, not the normal terminal) without having to do anything additional.

  • Are you connected to some WSL machine in VSCode?
  • Do you have Anaconda installed on the system?
  • Does Help → Toggle Developer Tools → Console show any error messages?
  • Now that you’ve added PIO to your PATH can you start pio home in a regular, e.g. cmd.exe, terminal?

Hmmm. Interesting. Can you have a look in the C:\Users\<myUsername>\.platformio\penv\Scripts folder and report back what files you see in there please? It sounds like the re-install hasn’t worked properly. Do you see a number of files, including pio.exe and platformio.exe at the very least?

If so, then I suspect that after adding the folder above to your PATH, you need to open a new command line session to get the updated %PATH% settings. (Been there, done that! :wink:)

Cheers,
Norm.

Thank you for your replies. Here is what I have found:

  • I’ve never installed WSL, so I don’t think that’s involved.
  • Anaconda is not installed
  • Developer Tools → Console shows the following:
    image
  • Typing pio at Windows cmd prompt returns ‘pio is not recognized as an internal or external command…’. I’ve confirmed that my path includes C:\Users\Matt.Barney\.platformio\penv\Scripts; when I type echo %PATH%
  • Here is the directory listing from the C:\Users\Matt.Barney\.platformio\penv\Scripts folder:
    image

This folder should contain platformio.exe, but somehow it does not.

grafik

What happens when you open a shell (Windows + R → cmd.exe) and execute

C:\Users\Matt.Barney\.platformio\penv\Scripts\pip3.exe install platformio

? Do you then have platformio available in the CLI?

Yes, after running that install, now I can run pio from Windows command line.

Does pio home open the PIO Home page?

Yes it does. From there, I created a new PIO project. When I build it, I get this warning, but then it successfully compiles:
**************************************************************************************************************************************************************************************************************Obsolete PIO Core v5.1.1 is used (previous was 5.2.0a6) Please remove multiple PIO Cores from a system: https://docs.platformio.org/page/faq.html#multiple-platformio-cores-in-a-system **************************************************************************************************************************************************************************************************************

From Windows cmd, I did pio system info, and it shows the multiple cores message, so I checked my PIO extension settings in VSCode and found Use built-in PIOCore unchecked, so I checked it. Build still gives the multiple cores error.

So from Windows cmd, I did pip uninstall platformio, which succeeded. But once again pio home no longer works.

Well, today is a new day… when I launched VSCode, it reopened to my most recent project, which was a PIO project. Then in the output pane of VSCode, it immediately displayed “Installing PlatformIO IDE…”, and then this status bar:
image

I don’t understand what initiated this PIO IDE installation.

After restarting VSCode, PIO home opens successfully, but the multiple cores error remains when I compile. Should I pip uninstall it from a PIO terminal within VSCode, or pip uninstall it from Windows cmd? (pip list from Windows cmd shows platformio 5.1.1 is installed, but the multiple cores error says “Obsolete PIO Core v5.1.1 is used (previous was 5.2.0a6)”.

Seems like the installation process was weirdly interrupt – the “Download portable Python interpreter” is normal during a PIO installation.

Do you have any Antivirus installed that could interfer? Sadly I do not have more advice than trying get rid of all cores but the one the PIO VSCode extension uses, maybe through another uninstall everything - reinstall.

Strangely enough, mine did exactly this too. I assumed, always a bad idea, that it was installing an upgrade to PlatformIO IDE.

Everything worked fine after the requested reload of VSCode.

Cheers,
Norm.

Thanks for your replies. I am unsure how to get rid of the ‘multiple cores’ error. I have “Use Builtin PIOCore” checked in VSCode settings, and when I do pip uninstall platformio, PIO Home stops working, as described above.

I uninstalled PIO IDE and VSCode, and then rebooted. I reinstalled VSCode. At this point, I noticed that the folder C:\Users\Matt.Barney\.platformio still exists and appears to be fully populated. Should I delete it manually after uninstalling in order to get a clean reinstall?

After installing PIO extension again, I noticed that .platformio\appstate.json contains: {"cid": "1b7338cd-9f05-9315-599b-eed87d2e0e75", "last_version": "5.2.0a6", "last_check": {"platformio_upgrade": 1625071616, "platforms_update": 1625071618, "libraries_update": 1625071621, "prune_system": 1624295061}, "settings": {"projects_dir": "C:\\Users\\Matt.Barney\\Documents\\Projects\\PlatformIO"}}

My company uses Security Manager AV Defender, which I am unable to turn off.

I decided to manually delete the .platformio folder. Then I reinstalled PIO IDE, and it works properly, with no “multiple cores” error. Thanks for your help.

1 Like