PlatformIO Community

Can't get output from serial monitor

Hi, I’ve been working with ESP-WROOM-32 development board and I’ve gotten it to work well before. Getting back into it after a while I suddenly can’t get any output from the serial monitor. I’m just running a simple test code in my main:

#include <Arduino.h>

void setup()
{
Serial.begin(115200);
}

void loop()
{
Serial.println(“Hello world!”);
delay(1000);
}

The serial monitor shows the correct output in Arduino IDE but not Platformio. I can’t seem to get any output.

Looks like it’s the same symptoms as discussed here: [SOLVED] ESP32 Serial monitor not working
However changing the settings doesn’t work.

Any ideas or suggestions would be greatly appreciated.

1 Like

You did set monitor_speed = 115200 in the platformio.ini (docs) if you’re using this baud rate, right?

1 Like

I tried adding that line in platformio.ini but it doesn’t change anything.

Doesn’t ‘Serial.begin(115200);’ override that value anyway?

No, PlatformIO doesn’t look into your source code and tries to figure out configuration parameters…

Can you show a screenshot of VSCode when you execute the Upload + Monitor project task?

1 Like

Here it is:

image

Although I’m using Atom with Platformio, not Vscode. I can only upload one image per comment

image

This is just the upload process, which is successful. You did press the Serial Monitor button in the menu right?

https://docs.platformio.org/en/latest/integration/ide/atom.html#platformio-toolbar

Yes, I clicked the serial monitor where you can see my cursor and opened it with the baudrate 115200. There’s no output from the monitor:

image

I just noticed the line “Changing baud rate to 460800”. Is there maybe an override somewhere?

Where does it say that?

In my first screenshot. 6th line from the bottom.

What confuses me the most is the fact that Arduino IDE gets the output as expected at the baud rate 115200 but ofc I’d like to stick to one IDE

This is during the serial upload, which is perfectly normal. Starts slow, then switches to a faster baud rate for upload.

Can you show a scerenshot of the serial monitor after you press “Start” with the correct COM device and baud rate?

Does it work when using an external serial monitor program like http://www.der-hammer.info/pages/terminal.html for the same COM port and baud rate (plus line break at LF/CR setting)

Not much to show, it doesn’t display anything:

image

Yes, it works with that program. Looks like the issue has to be somewhere in platformio, right?

Are you running the latest Plugin version? This issues seems to have been known: https://github.com/platformio/platformio-atom-ide/issues/2251

Yes, I have PlatformIO IDE ver 2.7.1 installed

Maybe I should switch to Vscode as they suggest in that thread…

I have he same problem. Switching to VSCode is not an option for me. Any suggestions? I run all latest versions. Output shows on Arduino software terminal.

I’m sure there are serial monitor plugins for Atom around though as a last resort?

According to this issue that was fixed the past. If it has resurfaced, please open an issue there, how are the devs going to know about it otherwise?

1 Like

I just realized that Visual Studio Code is not Visual Studio. I thought the suggested solution was to buy Microsoft software. I switched to VSCode and it’s working:)!

See the given menu help by pressing Ctrl+T and Ctrl +H in terminal.
Toggle DTR by pressing Ctrl+T and Ctrl+D this works for me fine.

This is because DTR and RTS both are connected to the RESET pin and GPIO 0 of the esp 8266 chip, and by default in the terminal serial port in visual studio code DTR and RST pin of the the serial to usb adapter are active and prevent the chip to act as normal.
Solution:
In terminal serial port press CTRL + T and then CTRL + D to inactive DTR and then CTRL + T and then CTRL + R to inactive RST pin.

https://docs.platformio.org/en/latest/core/userguide/device/cmd_monitor.html?highlight=dtr