Cannot upload to ESP32

It’s been awhile since I’ve done a project and I’m now getting back to a new ESP32 project where I’m encountering an issue when uploading. Last time I used PlatformIO (roughly 6-10 months ago), I had no issue. Now, I’m receiving the following error message:

Could not find the package with ‘platformio/tool-mkfatfs @ ~2.0.0’ requirements for your system 'windows_x86’

Here’s the terminal output:

Processing esp32dev (platform: espressif32; board: esp32dev; framework: arduino)
---------------------------------------------------------------------------------------------------------------------------------------------Tool Manager: Installing platformio/tool-mkfatfs @ ~2.0.0
Error: Could not find the package with 'platformio/tool-mkfatfs @ ~2.0.0' requirements for your system 'windows_x86'
The terminal process "C:\Python37\Scripts\platformio.exe 'run', '--target', 'upload'" terminated with exit code: 1.

Terminal will be reused by tasks, press any key to close it.

I’ve tried searching for solutions but can’t seem to find anything meaningful related to ‘tool-mkfatfs’.

When I opened PlatformIO recently, I did see that almost all of my platforms needed to be updated, so I updated them. But that is the only thing that I did other then creating a new project. I also tried some older ESP32 projects that did upload the last time I worked on them, and those are also failing to upload.

Any advice or suggestions would be appreciated.

See PlatformIO Registry. There is no native Windows 32-bit version of this tool in the PlatformIO registry, although it can be trivially compiled from source.

platform-espressif32 was updated to use the new Arduino-ESP32 2.0.0 framework. PlatformIO can auto-update your platforms.


platform = espressif32@3.5.0

in the platformio.ini instead of just platform = espressif32. Does it compile?

1 Like

Same problem in 32bit win 10
platform = espressif32@3.5

working fine! THX!

Issue is open in tool-mkfatfs for Win32 · Issue #778 · platformio/platform-espressif32 · GitHub.

1 Like

OK, so I’m up and running again. Here’s what I did:

  • Ran pio upgrade and then pio update.
  • Uninstalled the PlatformIO extension from VS Code.
  • Reinstalled PlatformIO
  • Changed my settings to Use Builtin PIOCore = True

After this, I was able to upload to my ESP32 dev board without issue.

I didn’t try changing my platform to platform = espressif32@3.5. But I would have if the above steps didn’t work for me.

Thanks everyone for the tips and suggestions… Its very much appreciated.

1 Like

Thanks, I’ve notified the people in tool-mkfatfs for Win32 · Issue #778 · platformio/platform-espressif32 · GitHub.