PlatformIO Community

All Project Tasks are grayed out

I am trying to setup VSCode+PlatformIO on a new machine. I have probably set it up 100x on various machines and lab computers. This time, after installing VSCode and PlatformIO, I created a project for an Arduino UNO. At this point, everything looked like it was working as expected.

However, every single item in the Project Tasks is grayed out. Build, Upload, Monitor, Upload and Monitor, Clean, and Clean All are all grayed out. Even all the options under Platform, Dependencies, Advanced, etc. are grayed out.

I have tried the following (multiple times):

  1. Deleted all the .vscode and .platformio folder.
  2. Uninstalling and re-installing VSCode and PlatformIO

It didn’t seem to fix it. Any suggestions?

1 Like

Have the same problem.

All the project tasks are disabled / grayed out in my installation. The short cuts and PIO CLI are working fine.

Screenshot 2022-09-01 230042

I think this might be related to the latest version of VSCode i.e. 1.71.0
I have options grayed out as well. Commands in pio CLI work fine.

Yes, I should have added that I did see that all the CLI stuff was working.

That was definitely it. We uninstalled and went back to 1.70.2 at it works as expected.

Can confirm this is caused by vscode 1.71.0.

You can disable automatic updates, and download 1.70 from here:

Then update later once fixed.

I had the same problem.

I use Windows and Chocolatey ( https://community.chocolatey.org ) and I think is easier to uninstall and install previous version of VS Code or other softwares.

choco uninstall vscode
choco install vscode --version=1.70.2
1 Like

CC @ivankravets possibly critical.

same problem here @maxgerhardt

How is made the command to build from CLI- ?

I have tried with
pio run --target build

but I got

*** Do not know how to make File target `build’ (C:\Users\simone.gasparella\Projects\iot_esp_platformio\build). Stop.

Building is done with no --taregt switch. pio run will build, pio run -t upload will upload.

1 Like

Did you downgrade your VSCode version as instructed above?

1 Like

ok @maxgerhardt I have to unistall or it is possible to downgrade from the gui?

Uninstall and reinstall with the link given in All Project Tasks are grayed out - #5 by louis, then disable automatic updates.

1 Like

The bug is already reported to the VSCode team

A temporary solution without VSCode downgrading is to use VSCode Menu > Terminal > Run Task > PlatformIO > ...

Let’s wait for any feedback from the VSCode team. The part of code that contributes TasksTree to the PlatformIO IDE extension has not been changed since 2020. It looks like a regression bug in VSCode.

The source code is supposed to be here. :wink:

1 Like

PlatformIO IDE v2.5.3 for VSCode is out. We added a workaround on our side. It is unclear how to hide private/internal commands from user space with the latest VSCode.

2 Likes