Xtensa-esp32-elf-g++: error: Controller.map: No such file or directory

I’ve tried to create a new simple project with the following setting, but it creates the issue that No such file or directory for Controller. map

platform = https://github.com/tasmota/platform-espressif32/releases/download/v2.0.2idf/platform-espressif32-2.0.2.zip
board = firebeetle32
framework = arduino

compiling process

Executing task in folder Motor Controller: C:\Users\Hamid\.platformio\penv\Scripts\platformio.exe run --environment firebeetle32 <

Processing firebeetle32 (platform: https://github.com/tasmota/platform-espressif32/releases/download/v2.0.2idf/platform-espressif32-2.0.2.zip; board: firebeetle32; framework: arduino)
---------------------------------------------------------------------------------------------------------------------------------------------------------------------------------Verbose mode can be enabled via `-v, --verbose` option
CONFIGURATION: https://docs.platformio.org/page/boards/espressif32/firebeetle32.html
PLATFORM: Espressif 32 (2.0.2) > FireBeetle-ESP32
HARDWARE: ESP32 240MHz, 320KB RAM, 4MB Flash
DEBUG: Current (esp-prog) External (esp-prog, iot-bus-jtag, jlink, minimodule, olimex-arm-usb-ocd, olimex-arm-usb-ocd-h, olimex-arm-usb-tiny-h, olimex-jtag-tiny, tumpa)
 - framework-arduinoespressif32 2.0.2
 - tool-esptoolpy 1.30200.211025 (3.2.0)
 - tool-mklittlefs 1.203.210628 (2.3)
 - toolchain-xtensa-esp32 8.4.0+2021r2
LDF: Library Dependency Finder -> https://bit.ly/configure-pio-ldf
LDF Modes: Finder ~ chain, Compatibility ~ soft
Found 30 compatible libraries
Scanning dependencies...
No dependencies
Building in release mode
Linking .pio\build\firebeetle32\firmware.elf
xtensa-esp32-elf-g++: error: Controller.map: No such file or directory
*** [.pio\build\firebeetle32\firmware.elf] Error 1
========================================================================== [FAILED] Took 2.41 seconds ==========================================================================

also, I tried to clean and delete the build folders, but it was not successful while my other previous project with the same setting works fine

any tips really appreciate

Does the path to your project folder has a space in it? Then you are running into Working with ESP Arduino 2.0.2 - #11 by maxgerhardt.