WT32-SC01 Plus wont Upload all of a sudden - No serial data received

I am fairly new to programming and using microcontrollers. I recently started using the WT32-SC01 Plus, and have been developing with it with few issues for the most part (I had trouble getting it to work when I first got it due to a lack of documentation but soon got it working). I was working on a project with this board when it started to crash right after connecting to wifi, when this happened I assumed something was off with my code, so I reverted to when it was working, but I was still getting the same crashes.

I created a new project with the same platform.ini and made a simple program where it would continuously serial print “working” just to see if I could get an idea of what the issue was. I uploaded it and everything was fine, it was printing “working” in a loop. So I tried to re-upload my normal sketch and from then on it has not uploaded. It would compile and get to the stage where it would connect to the serial port but then after selecting the port would give this error:


I have tried multiple different cables, USB ports and even a completely different computer. I don’t know if this is helpful but when I open the Serial monitor it shows the output of the last successfully uploaded program.

Here is the platform.ini file

platform = espressif32
board = esp32-s3-devkitc-1
framework = arduino
monitor_port = COM9
monitor_speed = 115200

build_flags =

and here is the last uploaded sketch

#include <Arduino.h>

void setup() {

void loop() {

I have tried holding down the reset button (the only button on the board) while uploading but it doesn’t work, nor does holding it down then plugging it in and uploading.

I am using platformio with Visual Studio Code

The board has been fine until now and I am very confused as to why it is no longer working.
Any help would be greatly appreciated.

Have you tried lowering the upload baud rate with e.g.

upload_speed = 115200

in the platformio.ini?

Hello, thank you for the suggestion, I have changed the upload speed to 115200, it successfully compiles but I get this error upon upload:

Can it be flashed via the Arduino IDE?

Thank you for the suggestion, I will try this now.

I tried using Arduino IDE but the same error as before:

And this error when changing the upload speed to 115200:

Is anything other than your serial adapter conencted to the serial pins of the ESP32-S3? Can you disconnect it from all external circuitry (that maybe also affecting the flash)?

Have you tried a different-type USB-to-serial adapter for programming?

I’m not sure, there are only a couple of pins available that the board exposes.

When I read Did something wrong with ESP32S3. Now bricked ? · espressif/arduino-esp32 · Discussion #7272 · GitHub it says to hold down the “boot button” while it’s trying to flash – maybe it doesn’t mean the reset button there put the GPIO0 bootloader switch button.

Acocording to the datasheet of the board the GPIO0 “boot” signal is available on the “DEBUG” header.

can you connect that to GND with a wire / jumper cable and retry flashing?

Edit: Yes the schematics also clearly show the button is connected to EN, not BOOT (GPIO0).

1 Like

Thank you, I will try this.

This seems to have fixed the issue, thank you so much I was getting very worried that I had somehow bricked my esp32. Again thank you so much, and thank you for your quick replies and useful suggestions.

Great that it’s restored again. And even if this method didn’t work, flashing via a direct USB connection to the ESP32-S3, you would still have access to the UART bootloader via the debug header (TX,RX, EN, GPIO0). The datasheet even says there’s a custom-made programming board for it.

1 Like


I am new here and have the same issue as above.

I canno’t figure out how you do the thing with the wire, can someone send a photo of the thing to do ?

Thanks in advance !