Windows r6034 error on (any?) platformio scripts running


#1

Hi,

I seem to be getting this error message when I run any platformio function, both through the CLI and IDE.

Has anyone seen something similar?
Core 3.4.0b2
IDE 2.0.0.beta.3

Regards,
Daniel


#2

What is your OS? Would be thankful for an output of these commands:

python -- version
pip --version

#3

Hi Ivan,

Windows 10
Python 2.7.12 :: Anaconda 4.2.0 (64-bit)
pip 9.0.1 from C:\PlatformIO\penv\lib\site-packages (python 2.7)


#4

Could you try to back your current system PATH and remove from that list a path to Anaconda’s Python. Then, please C:\PlatformIO\penv folder and restart Atom. It will install private Python2.7 into C:\PlatformIO\python27 and will use it for PIO Core calls and will not conflict with Anaconda’s pre-compiled Python.

So, after that, you can return back Anaconda’s Python into the system PATH.

P.S: Anaconda doesn’t install a clean version of Python interpreter. They have own pre-built versions…


#5

Apologies for replying to an old thread…

I recently installed PlatformIO and had the same issue above with Anaconda 2.4.0 installed (python 2.7.10 64-bit & pip 7.1.2).

Upgrading to the latest Anaconda 5.0.0 and following the “recommended” installation solved my issue. I note that Anaconda2 now does not recommend using the path environmental variable, instead it registers it’s python 2.7 default installation separately.


#6

I also am having the same issue but I don’t think I have Anaconda installed. I tried changing the Python path with no result. If you click ok on all the errors it appears to work ok. However trying to log in brings the same 8 error popups and results in Bad Credentials message. I tried forgot password which also brings up error popups and was followed by this is a registered account check for a message. Still waiting.

I get this from windows powershell

python --version
Python 2.7.14
pip --version
pip 9.0.1 from c:\python27\lib\site-packages (python 2.7)
PS C:\Users\steph> pip list
DEPRECATION: The default format will switch to columns in the future. You can use --format=(legacy|columns) (or define a format=(legacy|columns) in your pip.conf under the [list] section) to disable this warning.
adafruit-ampy (0.6.2)
appdirs (1.4.3)
arrow (0.10.0)
backports.ssl-match-hostname (3.4.0.2)
beautifulsoup4 (4.1.2)
boa-constructor (0.6.1)
bottle (0.12.13)
certifi (2017.4.17)
chardet (3.0.4)
click (5.1)
colorama (0.3.9)
cx-Freeze (4.3.1)
Cython (0.25.2)
distribute (0.7.3)
Django (1.7.4)
docopt (0.6.1)
docutils (0.13.1)
ecdsa (0.13)
esptool (2.1)
flup (1.0.2)
funcsigs (1.0.2)
idna (2.5)
Kivy (1.10.0)
Kivy-examples (1.10.0)
Kivy-Garden (0.1.4)
kivy.deps.glew (0.1.9)
kivy.deps.sdl2 (0.1.17)
lockfile (0.12.2)
matplotlib (1.3.1)
maxcube (0.0.1)
mock (2.0.0)
netifaces (0.10.4)
nose (1.3.0)
numpy (1.8.0)
packaging (16.8)
paho-mqtt (1.2)
paramiko (1.7.7.1)
passlib (1.6.2)
pbr (1.10.0)
PIL (1.1.7)
pip (9.0.1)
plyer (1.3.0)
psutil (3.2.2)
py2exe (0.6.9)
pyaes (1.6.1)
pycairo (1.8.10)
pycrypto (2.6)
PyDispatcher (2.0.3)
pyflakes (0.8.1)
pygame (1.9.2a0)
Pygments (2.2.0)
pygobject (2.28.3)
pygoocanvas (0.14.2)
pygtk (2.24.0)
pygtksourceview (2.10.1)
PyInstaller (2.1)
pyparsing (2.2.0)
pypiwin32 (219)
PyPubSub (3.1.2)
pyrsvg (2.32.1)
pyserial (3.4)
PySide (1.2.1)
python-dateutil (2.6.0)
pythonium (0.6.2)
PythonToolkit (12.8)
pywin32 (220)
requests (2.17.3)
semantic-version (2.6.0)
setuptools (28.8.0)
simplekml (1.2.1)
six (1.10.0)
SQLAlchemy (0.9.8)
tornado (4.1)
twisted (13.0.0)
urllib3 (1.21.1)
virtualenv (12.0.4)
web.py (0.37)
wheel (0.29.0)
WMI (1.4.9)
wxmplot (0.9.14)
zope.interface (4.0.5)

And this from PlatformIO Terminal

PS C:\Users\steph\Documents\PlatformIO\Projects\171014-172233-nanoatmega328> python --version
>>

Python 2.7.14
PS C:\Users\steph\Documents\PlatformIO\Projects\171014-172233-nanoatmega328> pip --version
pip 9.0.1 from C:\Users\steph\.platformio\penv\lib\site-packages (python 2.7)
PS C:\Users\steph\Documents\PlatformIO\Projects\171014-172233-nanoatmega328> pip list
DEPRECATION: The default format will switch to columns in the future. You can use --format=(legacy|columns) (or define a format=(legacy|columns) in your pip.conf under the
 [list] section) to disable this warning.
arrow (0.10.0)
bottle (0.12.13)
certifi (2017.7.27.1)
chardet (3.0.4)
click (5.1)
colorama (0.3.9)
idna (2.6)
lockfile (0.12.2)
pip (9.0.1)
platformio (3.5.0a16)
pyserial (3.4)
python-dateutil (2.6.1)
requests (2.18.4)
semantic-version (2.6.0)
setuptools (8.2.1)
six (1.11.0)
urllib3 (1.22)

#7

I just installed platformio on Win7 Pro and I’m also getting the dreaded R6034 error dialog. I have no python distros in my path (although I have several installed, including Anaconda3 5.0.1). If I issue ‘python’ and ‘pip’ commands from a cmd prompt, none are found.

 C:\>python
'python' is not recognized as an internal or external command,
operable program or batch file.

C:\>pip
'pip' is not recognized as an internal or external command,
operable program or batch file.

The same commands from PlaformIO terminal

C:\home\Documents\PlatformIO\Projects\180423-164835-espidf-ble-adv>python --version
Python 2.7.10

C:\home\Documents\PlatformIO\Projects\180423-164835-espidf-ble-adv>pip --version
pip 10.0.1 from c:\home\.platformio\penv\lib\site-packages\pip (python 2.7)

C:\home\Documents\PlatformIO\Projects\180423-164835-espidf-ble-adv>pip list
Package          Version
---------------- ---------
bottle           0.12.13
certifi          2018.4.16
chardet          3.0.4
click            5.1
colorama         0.3.9
idna             2.6
lockfile         0.12.2
pip              10.0.1
platformio       3.5.3b1
pyserial         3.4
requests         2.18.4
semantic-version 2.6.0
setuptools       39.0.1
urllib3          1.22
wheel            0.31.0

The R6034 error happens under both Atom and VS Code.

I tried whitelisting pioplus.exe in Win Firewall, which was suggested by another thread on this topic, but no joy.

Any help is much appreciated, as I’m stopped from using PlatformIO for my ESP32 development.


#8

As a followup, I wanted to see which python was being used. I got the following result in PlatformIO terminal (in VS Code).

C:\home\Documents\PlatformIO\Projects>python -c "import sys; print(sys.executable)"
C:\home\.platformio\penv\Scripts\python.exe

When I open a PlatformIO terminal in Atom I get the R6034 error dialog. I was then able to run the above command and got the same result. However, when I tried to copy the above from Atom terminal terminal text was not selectable, which is why I subsequently ran the test in VS Code.

There is no python in my path and Platform IO seems to think that the local copy of python is being referenced.