Windows Clean Reinstall

Hi All,

I had PlatformIO working on my windows 10 machine in VSCode some time ago. I’ve since worked on a number of other Python and Java projects.

Today I tried to open an old Platform IO project and the PlatformIO extension did not load. I opened the project by opening a folder within VSCode and it looked fine, but I did not get the PlatformIO toolbar appearing at the bottom of the screen and when I pressed ctrl + alt + t, I get a message in the toolbar saying Activating Extention which then disappears without the task list appearing.

I then uninstalled the PlatformIO extension and reinstalled it, exactly the same behaviour.

I then remove VSCode completely, by running the uninstaller, and deleting the folders C:\Users\.vscode and C:\Users<myuser>\AppData\Roaming\Code. From my understanding that should have completely remove VSCode and all the extensions.

I then reinstalled VSCode and the PlatfomIO extension, the extension downloaded the C/C++ extensions, but again the behaviour remains the same.

I then built a new Windows 10 VM and performed the same operation, only this time I noticed it informed me it was installing platformIO Core, which my previous reinstall attempt did not. So I repeated the reinstall on my dev machine and again it does not appear to download platformIO Core.

I think I’m not installing everything that needs to be removed, but any guidance will be greatly appreciated

Thanks, Darren

Remove the PlatformIO extension from VSCode, then remove the folder C:\Users\<user>\.platformio completely (removes the core). Then restart VSCode and install the PlatformIO extension again. Does it now install the core?

Don’t have the folder .platformio under my C:\Users<user>\ folder

Volume in drive C has no label.
Volume Serial Number is D658-DD9A

Directory of C:\Users\frewi

24/07/2021 16:45 .
24/07/2021 16:45 …
08/07/2020 20:28 57 .angular-config.json
24/01/2021 12:57 382 .bash_history
17/04/2021 08:46 .cache
08/07/2020 20:27 .config
04/07/2020 11:12 .eclipse
23/01/2021 14:00 276 .gitconfig
10/07/2021 14:02 .gradle
04/07/2020 18:37 .m2
07/07/2020 10:14 .QtWebEngineProcess
14/07/2020 13:38 .sts4
30/03/2021 21:08 .thumbnails
04/07/2020 11:12 .tooling
24/07/2021 16:45 .vscode
04/07/2020 10:37 3D Objects
04/07/2021 13:42 10,598 AMDRM_Install.log
04/07/2020 11:03 1,943,934 AMD_Chipset_IODrivers.log
04/07/2020 10:57 ansel
14/12/2020 19:46 Calibre Library
04/07/2020 10:37 Contacts
21/10/2020 06:49 37,165 Device_ID.log
04/07/2020 10:39 Documents
24/07/2021 14:58 Downloads
04/07/2020 10:45 Favorites
04/07/2020 10:37 Links
06/10/2020 19:32 Music
24/07/2021 12:19 OneDrive
10/07/2021 13:27 Postman
04/07/2020 10:37 Saved Games
04/07/2020 10:38 Searches
24/07/2021 12:19 Videos
6 File(s) 1,992,412 bytes
28 Dir(s) 234,320,736,256 bytes free

Then the core is already deleted. I’m sure when you Windows + R → cmd.exe → pio --version it returns command not found too?

Does it trigger the core installation now in VSCode? Is there any error message in the dev log (Help → Toggle Developer Tools → Console)?

Microsoft Windows [Version 10.0.19042.1110]
(c) Microsoft Corporation. All rights reserved.

C:\Users\frewi>pio --verion
‘pio’ is not recognized as an internal or external command,
operable program or batch file.


Still the same message in the toolbar saying Activating Extention which then disappears without the task list appearing.

What other extensions are installed? Is VSCode of the latest version? Anything suspicious in the console log?


Taking your point about the core already being deleted I follow the manual core installation process documented here Redirecting...

Everything now appears to work again. Clearly, there was something somewhere that made the extension think core was installed.

Thank you for your help and support on this…