PlatformIO Community

Win10 x64 VSC PlatformIO Home Page Load Problem


#1

Opened VSC after a couple of weeks and now the home page doesn’t load. I did the Update All and Core upgrade and then restarted but the home page still gives me this “error”

Any ideas on how to figure out what’s wrong?


#2

What happens when you run pio home? Your default web browser should automatically try to open the page, or if it doesn’t, got to the URL mentioned in the message that appears…


#3

When I run pio home a browser window does open (127.0.0.1:8008) and it just shows:

Cannot GET /


#4

All I can suggest is to close VSCode, delete the %USERPROFILE%\.platformio directory, and then start VSCode again. The PlatformIO extension will then reinstall all the core platformio files…


#5

I tried to do that and while in the process of deleting the folder Windows kept complaining the files were in use even though VSCode was closed. When I checked running processes I saw several pioplus (I deleted the processes so I can’t remember the exact name) as well as python several times.

Does PlatformIO always run some background processes and if so why?


#6

That was going to be the next check… to see if python was running in the background. Not normally. It suggests something is indeed stuck, so killing off all running the python tasks should free up that folder, and let a fresh install happen.


#7

Do you have antivirus tool in a system? It seems that it blocks PlatformIO installer. Could you remove %HOME_DIR%/.platformio/packages folder, disable antivirus tool, kill all pioplus.exe processes and restart VSCode. Does it work now?


#8

I’m just using the standard Windows Defender AntiVirus. I had many troubles so I used the brute force approach and had to uninstall PIO, delete the directory and start over.

It seems to be working now, or at least I get the home page instead of the “error”. Still not sure what caused this issue but I’ll keep an eye out

Thank you for your support.