PlatformIO Community

Wifi101 shield won't connect, works on Arduino IDE

I originally had a program I uploaded a couple weeks ago for my aquarium and it worked fine. I updated a couple things to the program and uploaded it. Now I can’t connect to my wifi. When I use the Arduino IDE it works fine with no changes from the platformIO IDE. So I’m using the test sketch “ConnectWithWPA” to troubleshoot the issue. Again, using the Arduino IDE 1.8.8 it uploads, runs, and connects flawlessly, but in platformIO it uploads, runs, but won’t connect. It gets hung up on connecting & never does connect. I’m using the WINC1501 model A shield on a Mega w/ newest FW 19.4.4. I tried the same test sketch using my MKR1000 & that works in both platformIO and Arduino IDEs like it should. I tried deleting all config/ resource files & reinstalling atom/platformio. I only installed the wifi101 library after the fresh install and it still behaves the same.

platformIO home : 2.0.0
platformIO core: 3.6.4
atom : 1.34.0 x64
wifi101: 0.15.3
Atmel AVR: 1.12.5

Any ideas or input would be greatly appreciated.

Do you use the same version of WiFi101 library?

The solution is here.

1 Like