PlatformIO Community

WHY? task errors, include compiling errors

why i get these two errors all the time. tried intellisense rebuild and nothing changed. also tried to split the NCO directory files into src and include … nothing changes.
task errors appear at every project i compile or upload

It sounds like for the tasks error issue, you’ve facing the same issue mentioned here:

A much shorter thread resolving this is here:

In a nutshell, somehow the "task.autoDetect": "off" in VSCode’s settings.json may have been set accidentally, probably when VSCode asked about a task slowing down your computer - not telling you that if you didn’t tell it to leave them turned on, that PlatformIO would stop working.

For the intelliSense ‘problem’/error, try adding the full sub-path to the start of your include statement… i.e.

#include <NCO\LUT_8bit.h>
or perhaps
#include <NCO/LUT_8bit.h>

thank you for the reply!!

i cant get it work with all possible types: “.h”, “NCO.h”, “NCO/.h” <.h>, <NCO.h> and <NCO/.h>

also tried rebuild intellisens … nothing change

i tried fining task.autoDetect in the settings json but this entry doesnt exist :frowning:

Can you give the output from higher up… the Dependency Graph… I want to see if PIO thinks it needs to download the library…

If you need to make any changes to the include path, you should be using build_flags = -I and specifying the directory to include… but that shouldn’t be needed if it’s in the \lib subfolder, as lib is in the standard include path. If you tried #include <LUT_8bit.h> also, I don’t know why that isn’t working for you … (note: I<, not "… they have a different meaning re: include path)… I made a mock header/cpp with that name and path, and it included just fine.

For the task autodetect, File -> Preferences -> Settings and search for task:

ok, i deletet NCO\ and now the lib is detected

ok, includ problem is gone so far, nothing really changed :smiley: i hate that…
task errors already occured after setting them to off and also a restart of visual code doesnt change.

1 Like

Yeah, that is bad… it’s one thing to fix a problem, is another to know WHAT you fixed! :laughing:

It need to be turned “ON”, not off… like in my screenshot!

How I understand it, task detection is how when you choose ‘Build’ from PlatformIO, VSCode knows what to do. If you turn that off, building stops working properly. You don’t want that! :wink: