Why did i lose all usb-serial support!?

Cannot see any esp board’s (tried about 5 diff types, 4 diff usb ports, 2 diff laptops, 3 different usb cables) cu.usb* does not appear anymore in my /dev/ folder.
I tried disabling SIP

tried these
sparkfun dot com/tutorials/how-to-install-ch340-drivers/all
and many more.

boards range from esp8266, esp32’s. all of which worked on my laptop just fine. i can def get to them via wifi etc but not my usb cables.

I HAD MacOSx 12.6.2 and no matter what driver i tried nothing. so i removed as much as i could find either app related or extension related and updated to Ventura. same issue. i was hoping that the MacOS would have its own drivers, but i might have messed that up already.

in the end, all i see is

 ~  ls -l /dev/cu.*                                                                                                 0|1 err | at 05:49:13 PM
crw-rw-rw-  1 root  wheel  0x9000001 Apr 11 17:49 /dev/cu.BLTH
crw-rw-rw-  1 root  wheel  0x9000003 Apr 11 17:44 /dev/cu.Bluetooth-Incoming-Port

which is very annoying.

In a terminal (possibly with root privileges) execute dmesg -w. When you now plug the USB cable out and in, do you see any new messages?

If not, it doesn’t even detect a new physical USB device. Use a different USB cable, port, or adapter. I’ve seen tons of Mac issues that were “oh my USB dock / adaptor was not working in this configuration…”