Where is Verbose Option on Build Specified?


#1

I’m trying to build a TASMOTA image using VS Code and the PlatformIO IDE. This is my first project using VSC & the PIO IDE. I used the Arduino IDE successfully, but it continue to be unstable from one invocation to the next.

I am getting an error and I want to enable verbose mode on the run to see if it gives any additional clues as to what is causing the error. I cannot figure out where to specify the --verbose option.

While I’m here, here is the terminal window output in case this is a straightforward problem resolution:

> Executing task: C:\Users\miingr\.platformio\penv\Scripts\platformio.exe run <

Processing sonoff (platform: espressif8266@1.7.0; board: esp01_1m; framework: arduino)
-------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------
Verbose mode can be enabled via `-v, --verbose` option
PLATFORM: Espressif 8266 > Espressif Generic ESP8266 ESP-01 1M
SYSTEM: ESP8266 80MHz 80KB RAM (1MB Flash)
Converting sonoff.ino
Library Dependency Finder -> http://bit.ly/configure-pio-ldf
LDF MODES: FINDER(chain) COMPATIBILITY(soft)
Collected 43 compatible libraries
Scanning dependencies...
Dependency Graph
|-- <ESP KNX IP Library> 0.5.1
|   |-- <ESP8266WiFi> 1.0
|   |-- <ESP8266WebServer> 1.0
|   |   |-- <ESP8266WiFi> 1.0
|   |-- <EEPROM> 1.0
|-- <PubSubClient> 2.6
|-- <TasmotaSerial> 2.0.0
|-- <ArduinoOTA> 1.0
|   |-- <ESP8266mDNS>
|   |   |-- <ESP8266WiFi> 1.0
|   |-- <ESP8266WiFi> 1.0
|-- <TasmotaMqtt> 1.0.0
|-- <Joba_Tsl2561> 2.0.1
|   |-- <Wire> 1.0
|-- <IRremoteESP8266> 2.2.1
|-- <ESP8266httpUpdate> 1.1
|   |-- <ESP8266HTTPClient> 1.1
|   |   |-- <ESP8266WiFi> 1.0
|   |-- <ESP8266WiFi> 1.0
|-- <ESP8266mDNS>
|   |-- <ESP8266WiFi> 1.0
|-- <ESP8266WiFi> 1.0
|-- <Adafruit SGP30 Sensor> 1.0.2
|   |-- <Wire> 1.0
|-- <ESP8266WebServer> 1.0
|   |-- <ESP8266WiFi> 1.0
|-- <C2Programmer> 1.0.0
|-- <ESP8266HTTPClient> 1.1
|   |-- <ESP8266WiFi> 1.0
|-- <BME680_driver-bme680_v3.5.9>
|-- <I2Cdevlib-ADS1115>
|   |-- <I2Cdevlib-Core>
|   |   |-- <Wire> 1.0
|-- <DNSServer> 1.1.0
|   |-- <ESP8266WiFi> 1.0
|-- <ESP MQTT> 1.0.1
|-- <ArduinoJson> 5.11.2
|-- <OneWire> 2.3.2
|-- <NeoPixelBus> 2.2.9
|   |-- <SPI> 1.0
|-- <Mutichannel_Gas_Sensor> 0.0.1
|   |-- <Wire> 1.0
|-- <Wire> 1.0
|-- <SPI> 1.0
|-- <Ticker> 1.0
Compiling .pioenvs\sonoff\src\sonoff.ino.cpp.o
In file included from C:/Users/miingr/Documents/PlatformIO/Projects/TASMOTA/sonoff/sonoff.ino:35:0:
sonoff\user_config_override.h:24:2: warning: #warning **** user_config_override.h: Using Settings from this File **** [-Wcpp]
#warning **** user_config_override.h: Using Settings from this File ****
^
Linking .pioenvs\sonoff\firmware.elf
Checking size .pioenvs\sonoff\firmware.elf
Building .pioenvs\sonoff\firmware.bin
'"esptool"' is not recognized as an internal or external command,
operable program or batch file.
*** [.pioenvs\sonoff\firmware.bin] Error 1
Memory Usage -> http://bit.ly/pio-memory-usage
DATA:    [======    ]  63.1% (used 51724 bytes from 81920 bytes)
PROGRAM: [=====     ]  46.4% (used 486241 bytes from 1048576 bytes)
============================================================================================== [ERROR] Took 13.39 seconds ==============================================================================================

======================================================================================================= [SUMMARY] =======================================================================================================
Environment sonoff              [ERROR]
<snip>    
  
  ============================================================================================== [ERROR] Took 13.40 seconds ==============================================================================================
        The terminal process terminated with exit code: 1

The esptool notification appears in the output in yellow as does the user_config_override.h warning. The header file has this warning message in it to ensure the user gets that notification. I do not know if the esptool message is that relevant as I am only trying to compile and link the image first. I think that esptool is used to flash the device… I’m uploading via the serial interface. I’m not sure that esptool is used in my setup. But, as I said, I’d first like to get to a successful build.

Regards.

Mike


#2

Use one of: