PlatformIO Community

WARNING: VSCode 1.57.0 prevents PlatformIO executing

Good Morning All.

Apologies for the slightly scary title to this post, but now I have your attention… :wink:

I’ve just updated to VSCode 1.57.0 this morning and it has a new feature, trust, which allows you to specify if the code in a folder/workspace is to be trusted or not.

Trusting the folder/workspace allows extensions to be used as normal.

Not Trusting the folder/workspace, prevents all your extensions, including PlatformIO, from running. No PlatformIO toolbar will appear if a folder is untrusted.

There are settings to enable/disable this, and the default is to ask once per folder. Once trusted, it’s fine for all time. (Even if you delete the folder, recreate it and put some completely different code into it!)

So, if you don’t see the PlatformIO toolbar, and there’s a blue band across the top of the window which mentions “restricted mode” check the folder/workspace’s trust by clicking the “Manage” link. You can add the folder in the management window.

Have fun!

Cheers,
Norm.

3 Likes

hmm, I’ve lost PIO as well. vscode 1.57.0 says it’s installed,did the delete, closed vscode, restarted vs code reinstalled pio, closed vs code restart but still not being recognized I went through the folder security all looks good but no PIO

I can say it at least works for me.

grafik

You can maybe try a full reinstall of PlatformIO (remove the extension, remove C:\Users\<user>\.platformio, reinstall extension) or look in Help → Toggle Developer Tools → Console if there are any errors.

Otherwise try and disable the trust feature in File → Preferences → Settings.

grafik

My setup has a couple of issues.
1, C++ extensions failed to load. I did a manual GitHub download and manual install via visix ( in the extension drop down menu) Once installed I did a restart of VScode and Platformio became operational. So good to go.
2, I tried to compile an existing esp8266 project but the extensa toolkit appears to have some download issues on an amd64. I’ll need to figure that one out yet.
I live in an area in Canada that has some internet performance problems so I just need to be patient and walk through issues.

I got a few dialogs asking me if I trust the authors of those directories, I said yes, and everything seems to work.