PlatformIO Community

Warning! Please install `99-platformio-udev.rules` keeps showing up


#1

Hi

This message keeps showing up, when trying to upload the code to an Arduino Nano board:
Warning! Please install 99-platformio-udev.rules and check that your board’s PID and VID are listed in the rules.
https://raw.githubusercontent.com/platformio/platformio/develop/scripts/99-platformio-udev.rules

I followed the installation guide, but it does not make any difference. I have tried to place the “/99-platformio-udev.rules” file in “/etc/udev/rules.d/” and also tried “/lib/udev/rules.d/”, but it did not make any difference

My OS is Linux Mint 173, x64

Hope somebody have a solution :slight_smile:

Best regards, Brian


#4

Thanks!

See http://docs.platformio.org/en/latest/faq.html#platformio-udev-rules

Fixed in


#5

Hello,
I get the same error.:slightly_frowning_face:

Warning! Your /etc/udev/rules.d/99-platformio-udev.rules are outdated. Please update or reinstall them.
Mode details: https://docs.platformio.org/en/latest/faq.html#platformio-udev-rules

I use Linux Disco dingo and installed the files.
Hope somebody have a solution!
Thank you!


#6

Did you you restart the udev service after downloading the udev rules file, and also add your user to the dialout and plugdev groups, and then log out and back in (or just reboot) again to apply the group changes?


#7

I’m puzzled: I get the same warnings, the user is in dialout / plugdev and the system has been rebooted multiple times since installing the rules. Also, flashing works without a problem, just the message coming up anyway.

The file in .platformio/penv/lib/python2.7/site-packages/platformio/builder/tools/pioupload.py doesn’t look like that mentioned in @ivankravets patch but it was so long ago that a lot might have changed since then. I’m using vscode and pio 3.6.7 for the record.


#8

Did you copy https://docs.platformio.org/en/latest/faq.html#platformio-udev-rules ?


#9

I thought I had because I recalled reading about it during installation and because flashing works but honestly… if I had, now it’s gone so the odds are not exactly in my favour :wink:

Thanks for pointing it out. I also have a couple of rule files that I installed for OpenOCD, it’s quite likely one of them is the reason flashing works.


#10

Yes, I copied the file and restart multiple time but the result is the same. The program works correctly but I’m get always the warning.
How can I verify the correctly useradding in dialout and plugdev?
Thanks!


#11

If you type groups at a terminal, it will tell you what groups your username is in.

ie.

pfeerick@ASUS-H55D-ubuntu:~$ groups
pfeerick adm dialout cdrom sudo dip plugdev lpadmin sambashare

#12

I get the same answer with my username.


#13

I have the same problem, I would love to know what im doing wrong :frowning:
I have done what the instructions say several times and still the warning


#14

It seems that you installed the latest udev rules from development branch of PlatformIO Core 4.0 but use PlatformIO Core 3.0. What is your pio --version?


#15

Hello, I am also getting this error on Ubuntu Disco Dingo (19.04). I followed the instructions and rebooted several times. As others have stated, the flashing is working fine but I don’t want to see this error message. Thank you!


#16

What is your PIO Core version? Type in terminal

pio --version

#17

Hi, the PIO version is: PlatformIO, version 3.6.7
Thanks!


#18

I’ll just add that I’ve got the same issue (although I seem to think it only started within the last couple of weeks), but hadn’t bothered doing anything about it as everything is working fine. PlatformIO, version 3.6.7, and I reapplied the udev rules last week. Ubuntu 19.04 also FFIW. There is no /lib/udev/rules.d/99-platformio-udev.rules so there’s no conflicting versions.


#19

Ubuntu 18.04, pio version is 3.6.7, I followed installation procedure form faq but still get warned that the udev rule is outdated.


#20

Anyone still having trouble, can you try the command from the FAQ to update your udev rules … (note: this is the copy of the udev rules from the develop branch, not the master branch, so may actually cause an ‘outdated udev rules’ message if you don’t currently have one…).

curl -fsSL https://raw.githubusercontent.com/platformio/platformio-core/develop/scripts/99-platformio-udev.rules | sudo tee /etc/udev/rules.d/99-platformio-udev.rules

… again, and see if you are still having trouble. I’m still on PlatformIO 3.6.7, but the warning seems to have gone away? Also, if you are still have the warning… can you please check the wording… Is it saying to install it, or that it is outdated - there are two different warnings that can be triggered/shown.


#21

@ivankravets I do have the PIO ver Core 3.6.7. Where do i get the udev.rules for that version from?

Thanks


#22

If I’m reading the specific function that does the outdated udev rules check right, (so you’re getting the ‘outdated’ rules message, not the ‘please install’ message?), it seems like the comparison is being done against the copy of the udev rules included at .platformio/penv/lib/python2.7/site-packages/scripts/ in your home directory… i.e. Linux: ~/.platformio/penv/lib/python2.7/site-packages/scripts/ or Windows: %USERPROFILE%/.platformio/penv/lib/python2.7/site-packages/scripts/

You can also compare it to this version, which is the one for 3.6.7 (it’s from the master branch, not the develop branch), and can be installed like :

curl -fsSL https://raw.githubusercontent.com/platformio/platformio-core/master/scripts/99-platformio-udev.rules | sudo tee /etc/udev/rules.d/99-platformio-udev.rules