VSCode stuck on 'Initializing PlatformIO Core...'

I have been working with VSCode 1.70.2 (previously 1.70.3) and PlatformIO 3.3.1, on Win7 (32bit) for the last few weeks.

I was pretty happy with the setup, but a couple days ago the toolbar at the bottom disappeared (the one with home, build, upload, etc…)

I read several threads (here and other places) and someone said to delete parts of the /users/mark/.platformIO folder. This didn’t work.

I uninstalled PlatformIO from VSCode and reinstalled, Also, no.

I uninstalled PlatformIO AND VSCode and reinstalled, that didn’t work either.
Sadly, I ended up with an older version of VSCode

Can someone please help me diagnose this?
I am new to both VSCode and PlatformIO so don’t know where to look for logs and such.

Thanks, Mark.

Edit. I installed VSCode on a different computer (also Win7 32bit) and installed the PlatformIO extension, and get the same result. It is stuck at “Initializing PlatformIO Core”

OK I solved it. Somehow the entire /Users/mark/.platformio folder got deleted. I don’t recall doing that when I removed some of it’s sub folders, but maybe I’m an idiot.

I tried to use PIO in Code::Blocks, and Eclipse (never got those installed) then I read somewhere the PIO part is a command line only utility.

I went to install the PIO CLI tools and used the “get-platformio.py” script and it recreated that folder.

2 issues here…
#1, Why isn’t that folder created (or recreated) when the extension is installed from VSCode?, and
#2, getting the get-platformio.py was a bit confusing. I had to open the raw page, highlight the code, then copy and paste it into my text editor and save it.

Now, I may have deleted that folder on computer 1, but…

I tried a fresh install of VSCode and PlatformIO on computer 2 yet it had the same problem.

On computer 2, I think I tried to install the PlatformIO extension before installing Python, realized my mistake, installed Python and reinstalled PIO extension.

I detect a bug here where it doesn’t really install the extension if it thinks it has been installed previously.

Anyway, all seems well in PlatformIO land, and after several days, peace reigns over my psychosis again. Time to go rake the leaves before it snows.


How do I mark this thread as solved?