VSCode: Property ! WARNING ! is not allowed

I’ve been trying to set up this project but can’t seem to figure out these errors. I’m sure it’s something easy that I’m missing but any help would be greatly appreciated!

So have you tried an Intellisense rebuild (docs)? Have you got other C/C++ Intellisense plugins installed besides the one from Microsoft?

I believe I have. I run the “Rebuild IntelliSense Index” and it doesn’t really do anything except give me this error: “Property !!! WARNING !!! is not allowed.”

As for the plugins, I have the following installed:

The ‘Arduino for Visual Studio Code’ extension causes problems with PIO, I’d uninstall it.

Probaly also disable the “C++ Intellisense by austin”, I’m sure Ivan said it clashed in another post.

If it were me, I’d disable all but the PlatformIO and Microsoft C/C++ extensions, see if it works, and then try turning on the extensions one by one to see what ones are compatible. That’s if you need them all.

I uninstalled it but no luck. The errors are still the same.

Tried that but nothing changed. What’s annoying is that it’s a pretty simple project using some Arduino and Adafruit libraries so I think that I should really only need the C/C++ and PlatformIO extensions but if there’s one that I’m missing please let me know!

No, nothing missing… for bog standard Arduino with PlatformIO, you only need those two. The warning about "Property !!! WARNING !!! is not allowed.” is due to an update to the C/++ extension, and can be safely ignored.

Only other thing I can readily think of to look at is what is in your platformio.ini file? i.e. Does it have a framework = arduino line for the environment you’re trying to build/compile?

Fixed in

The PlatformIO Core 3.6.6 is coming next week. You can switch to PIO Core development version using platformio-ide.useBuiltinPIOCore settings. Please don’t forget to restart VSCode.