VScode plugin Installation hang


I’m trying to install the platform IO vscode extension, but it does not work. The “installing” popin hang forever. I tried already to re-install with no luck. Also tried to remove ~.platformio/ directory and re-install, but still got the same issue.

My config

  • I’m using MacOS Big Sur
  • platform io cli has been installed successfully and works (pio command works)

When I toggle the VSCode dev tools I can see the following logs (see attached screenshot)

Screenshot 2020-12-04 at 10.34.17

Is anybody have a clue/idea to help me have this work? I can provide more information if needed.

The first error looks like… Jupyter was installed as some insiders version, or your VSCode is an insiders version?

The second warning seems to be a main culprit. What’s inside the /Users/adrien/.platformio/penv/bin folder?

Also you can try to remove the PIO VSCode extension again, remove /Users/<user>/.platformio fully, install Python 3 via the FAQ (mind the notes) and use the preferred installer script here, then re-install the PIO VSCode extension.

Thank you very much I got it work eventually.

What I’ve done:

  1. uninstalled pyenv and the current python3 related I was using.
  2. Then install python3 using install Python 3 via the FAQ
  3. Installed platform io using installer script