VSCode +PlatformIO +ESP32S3-N4R8 +Arduino

I have a board ESP32S3 with 8MB PSRAM (N4R8), on Arduino IDE, when I choose QSPI, in PSRAM selection, the PSRAM not detected, I have to choose OPI so the PSRAM detected and read as 8MB, I couldn’t find a way to change that in the platformIO, all the supported boards are 2MB PSRAM, I tried to change the memory type in the board’s .json file from qio to opi , but nothing works, How to change the PSRAM type to be detected by the platformIO? any advise please?

Set memory_type accordingly, check out Enable OPI PSRAM and 16MB QIO80MHz of FLASH - #2 by maxgerhardt.

Thanks for your replay, I already tried this, when I added any of theses lines(or all of them) into *.ini file, ESP crashes

board_build.arduino.memory_type = qio_opi
board_build.f_flash = 80000000L
board_build.flash_mode = qio

Can you screenshot the Arduino IDE → Tools menu with which it works in the Arduino IDE?

the setting as shown below

What’s the used Arduino-ESP32 version? Tools->Boards->Board Manager → esp32.

as shown in the previous screenshot, it is ESP32S3 Dev Module, shown in the screenshot below.

No, I want to know what Arduino-ESP32 core version is used. For example, 2.0.7.

it is Espressif System 2.0.7 as shown below

Make sure the same core version is used in PlatformIO, e.g. by using a CLIpio pkg update -g -p espressif32.

Are you testing this with the minimalist possible code?

#include <Arduino.h>
void setup() { Serial.begin(115200); }
void loop() { Serial.println("test"); delay(1000); }

it work just fine with Arduino IDE, I’m using PlatformIO with VSCode, which what I have issue with, the PSRAM not detected by the ESP32, I have another board with 2MB PSRAM, which work just fine with the same code, the *.ini file as below, i commented the last two line so the code works, otherwise, it crashes :

board_build.filesystem = littlefs
framework = arduino
build_flags =
;board_build.arduino.memory_type = qio_opi
;board_build.flash_mode = qio

it is the same version, I tried minimalist possible code, still crashes