VSCode - Outline do not show all Methods

I’m using PlatformIO with VSCode, and it happen that the Outline View do not show all method available in the code:


Any suggestions? Many Thanks


Well for me it does update the Outline but only very slowly, like every 10-20 seconds. Do you get the same when you just type a new function and wait?

Also, this seems more like a bug / setting in VSCode or the Microsoft C++ extension rather than the PIO plugin.

Hi @maxgerhardt,
test routine is created yesterday and I opened closed VSCode many time.
Do you know where I can get support on Microsoft C++ extension?


Hi have another PC, same version of all components, and on this other PC, all Method are visible in Outline. Just tried to remove/reinstall C++ plugin on PC not working but nothing change

I think it’s an update rate issue. When you add a new function and it doesn’t show up, does switching between PIO and the explorer on the left sidebar help? Or executing the build task?

hi @maxgerhardt
yes tried all things you mentioned, also tried to uninstall C++ plugin and reinstall, also tried to restart VS Code, but on my 1st PC does not show up some methods, on my other PC yes.


well you need to complete the method first, add a semicolon after i++ in your method. i believe this would make the method appear in outline view.
VScode doesnt show incomplete methods in its outline view. this would also happen if, say, you were missing a bracket or so.