PlatformIO Community

VScode ESP32 Build error Could not find one of "library.json, library.properties..." manifest files in package

Hey guys,
It has been a while, that I was working on my ESP32 project in VScode and today I tried compiling my code for the first time and now I am struggling with the error message:
Error: Could not find one of ‘library.json, library.properties, module.json’ manifest files in the package

I have already tried deleting the .cache and packages folder without success. This is my ini-file

[env:firebeetle32]

platform = espressif32

board = firebeetle32

framework = arduino

upload_port = COM3

lib_deps =

    256dpi/MQTT@^2.5.0

    bblanchon/ArduinoJson@^6.17.3

    paulstoffregen/Time@^1.6.1

    adafruit/Adafruit ADS1X15@^2.2.0

    adafruit/Adafruit BusIO@^1.9.3

    Wire

I have PlatformIO 6.1.3
Anybody here with an idea to fix this issue?

EDIT: I also tried

  • Deleting everything inside the “platform” folder
  • Uninstalling/re-instlaling platformio (obviously also restarting PC)
  • Deleting all entries in platformio.ini under lib_deps → Building would now start but obviously fail due to missing libraries
  • On another laptop the same project (same github repo) compiles just fine…

Help is highly appreciated, since I was not able to have any progress yet.

I only noticed that I am able to compile other platformIO projects in VScode

Did you remove the .pio folder of the project and retry?

Remove Wire from your libs_deps It is included in framework or do you want to use OneWire ?

Thank you both for your answers.

This was actually the key. It immediately started to compile.

I am actually not using OneWire but I had to add the library, otherwise it wouldnt compile. Maybe there was some internal framework issue.

There is no internal framework issue. Never add a 3rd party wire lib to espressif32 framework. This will never work.
If it does not compile without you have a other problem. Try a simple demo sketch (blink) which does not need any libs.