VSC: No task to run found


new year with unexpected poblems !

I had a notification about “something is slow…” and so on, but as I did not understand the message (I was in the heat of a code-problem situation and about to crack it…) so I just pressed the “x” in the right up corner of the message and NOT the buttons.
The result is that I cannot build my project anymore, because the tools will not start.

As I have understood there are others who have wrestled with this same problem and have solved it by deleting a line “autoDetect…” in the settings.json-file.
I cannot do that because my .json file does not have that item (my file contains only “C_Cpp.errorSquiggles”: “Enabled”).

Done so far:
-deleted the project directory .vscode, same problem exists
-created a new project, same problem exists
-did the “pio init --ide=vscode” procedure via the PIO terminal, same problem exists

My setup versions:
-Platformio IDE 1.10.0
-Home 3.0.1
-Core 4.1.0
-VSC 1.41.1 (system setup)

And yes, I have read the threads “PIO, VSC can’t build, no tasks found” and “No task to run…found”. But suggestions in those threads have not solved the problem.

Any ideas ? PlatformIO Team ?? Anybody ???

with best regards,

Well then maybe adding "task.autoDetect": "on" helps settings.json to explicitly turn it on? Just a shot in the dark

Good guess but did not help.

I added “task.autoDetect…” to “settings.json” of my project as:
“C_Cpp.errorSquiggles”: “Enabled”,
“task.autoDetect”: “on”

I also tried to create a task template as the message box suggests:
Select the task to run
No task to run found. Configure Tasks…

Select a task to configure
Create tasks.json file from template

Select a Task Template
MSBUILD Executes the build target

There were 3 other templates, I chose MSBUILD.
VSC then created a file “tasks.json”, which was possible to run.

But no use because the terminal printed:
‘msbuild’ is not recognised as an internal or external command,…
…with exit code: 1

Found the cure, it was related to the god damned autoDetect.
In my case the solution was to change it via MyProjectDirectory-settings:

RightClick to open selections and select: Open Folder Settings

then opens a setup window for 3 items:
User Workspace ProjectDirectory

select User and then Features/Task: Auto Detect: off

I had Auto Detect: off (for reasons totally unknown to me), changed it to “on” now the build again works.

Big thanks to maxgerhardt for your effort !!

Back in coding…


Sorry I am trying to follow your instructions but I’m on Win10 … Are you doing that from VSC ? From Windows explorer ?
Thank you

It’s a VSCode setting.

  1. File -> Preferences -> Settings
  2. Click the User tab (mine shows User and Workspace as options at the moment)
  3. Search for ‘task detect’ (input/search box near the top)
  4. Make sure Task: Auto Detect is turned on (default setting)

Got it, … and it worked :+1: !

You saved my day…

Thank you

1 Like