PlatformIO Community

ValueError: Invalid simple block '^2.4.5platformio':

Hello,
In my platformio.ini file I have add the library “adafruit/Adafruit NeoPixel @ ^1.8.1”

lib_deps =
# RECOMMENDED
# Accept new functionality in a backwards compatible manner and patches
paulstoffregen/Time @ ^1.6
# RECOMMENDED
# Accept new functionality in a backwards compatible manner and patches
adafruit/Adafruit GFX Library @ ^1.10.7
# RECOMMENDED
# Accept new functionality in a backwards compatible manner and patches
adafruit/Adafruit SSD1306 @ ^2.4.5platformio
# RECOMMENDED
# Accept new functionality in a backwards compatible manner and patches
claws/BH1750 @ ^1.2.0
# RECOMMENDED
# Accept new functionality in a backwards compatible manner and patches
adafruit/Adafruit NeoPixel @ ^1.8.1

but now when I build my project i get this error:

ValueError: Invalid simple block ‘^2.4.5platformio’:

Can someone help me?
Thank you so much.

When I go to A professional collaborative platform for embedded development · PlatformIO I don’t see the platformio part being there. Just

lib_deps =
     # RECOMMENDED
     # Accept new functionality in a backwards compatible manner and patches
     adafruit/Adafruit SSD1306 @ ^2.4.5

which is correct. Try to correct it to that form.

Hello @maxgerhardt,
Thank you for your quick help.
As you can see I was tired yesterday and completely overlooked the word “platformio” in the lip_deps. And I was overwhelmed with the error message. Sorry.
Because of my second screen, I keep writing something in the wrong window without noticing it because the cursor is in the wrong position…
I wish you a nice day and thank you again!