Uploading ESP32 to ESP 83266

This has come up before. It’s persistent.
I have one script open. The .ini file clearly calls for ESP 8266.
PIO is trying to upload to ESP32.

I re-opened PlatformIO, restarted the computer. It says it built- for ESP32. So it has read the .ini file and ignores it?

What’s this?
How do I reset PIO’s target board?

Do you have an ESP8266 and ESP32 connected to the computer at once? If yes, it can’t tell the difference between those two boards.

Otherwise, make sure you’ve selected the right active project, as this has changed in recent extension versions.

Only the 8266 is connected, and only the 8266 script is open, along with the .ini.

I followed that link, but I don’t see anything about selecting the project, or making sure the selected project is correct?

That’s what I was looking for. I was looking for a place where the last sessions settings might be loitering. But I see no such thing.

The “project environment switcher at the bottom”.

Awesome. Somewhere.
It says this:
PS C:\Users\joema\Documents\PlatformIO\Projects\TFT_ESP32>

That is the last script. I made that after I couldn’t upload to the 8266.
So I opened the original script, and it says this:
PS C:\Users\joema\Documents\PlatformIO\Projects\ISS_Feerick_WeMos8266>
I ran Build, and it failed- appropriately, because I do not have any of the libraries. But it built for Esp32, not 8266.
I ran Build earlier, and it claimed success for Esp32 despite no libraries.

The next button, ‘default’ shows the board.